9ac63a3360
Commit7991d2c48a
wrongly removed patch added by commit1e8cce6f2b
, advocating that upstream applied a different "solution", this "solution" was already tested on buildroot with commit9525bc7e64
and is utterly broken as stated in: https://github.com/libarchive/libarchive/pull/1825#issuecomment-1403537856 https://github.com/libarchive/libarchive/pull/1825#issuecomment-1437451472 https://github.com/libarchive/libarchive/issues/1819#issuecomment-1439962521 https://github.com/libarchive/libarchive/issues/1841#issuecomment-1426628554 https://github.com/libarchive/libarchive/pull/1813#issuecomment-1396373372 As a result, build failures are again raised by uclibc-ng with libiconv on fwup/gvfs/...: configure: error: Requires libarchive. Libarchive must be built with zlib support. [...] Run-time dependency libarchive found: NO (tried cmake) ../output-1/build/gvfs-1.48.1/meson.build:405:2: ERROR: Dependency lookup for libarchive with method 'pkgconfig' failed: Could not generate cargs for libarchive: Package iconv was not found in the pkg-config search path. Perhaps you should add the directory containing `iconv.pc' to the PKG_CONFIG_PATH environment variable Package 'iconv', required by 'libarchive', not found So revert the upstream "solution", put back previous patch and let's hope that upstream improve their skills in pkg-config and static building but they probably don't really care about it... Fixes: - http://autobuild.buildroot.org/results/0f5058634ecc2ffae3993f6f4513d8ce75e6c02f - http://autobuild.buildroot.org/results/20fc291ef7e37ee8bd553976cbe841e53345680b Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
From 3879afd473a256173cc626e16293f3fe8875f2d6 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Sat, 6 Jan 2024 09:53:23 +0100
|
|
Subject: [PATCH] Revert "Only add "iconv" to the .pc file if needed (#1825)"
|
|
|
|
This reverts commit 1f35c466aaa9444335a1b854b0b7223b0d2346c2.
|
|
|
|
Upstream: no dedicated PR for this revert but there is already plenty of PRs/issues to fix iconv build ...
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
configure.ac | 4 +---
|
|
1 file changed, 1 insertion(+), 3 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 93f7af94..204a4e69 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -434,9 +434,7 @@ if test "x$with_iconv" != "xno"; then
|
|
AC_CHECK_HEADERS([localcharset.h])
|
|
am_save_LIBS="$LIBS"
|
|
LIBS="${LIBS} ${LIBICONV}"
|
|
- if test -n "$LIBICONV"; then
|
|
- LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
|
|
- fi
|
|
+ LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
|
|
AC_CHECK_FUNCS([locale_charset])
|
|
LIBS="${am_save_LIBS}"
|
|
if test "x$ac_cv_func_locale_charset" != "xyes"; then
|
|
--
|
|
2.43.0
|
|
|