package/libarchive: fix uclibc with libiconv build
Replace patch added by commit 9525bc7e64
as current patch is not correct, build failures are still raised by
uclibc-ng with libiconv on fwup/gvfs/...:
configure: error: Requires libarchive. Libarchive must be built with zlib support.
[...]
Run-time dependency libarchive found: NO (tried cmake)
../output-1/build/gvfs-1.48.1/meson.build:405:2: ERROR: Dependency lookup for libarchive with method 'pkgconfig' failed: Could not generate cargs for libarchive:
Package iconv was not found in the pkg-config search path.
Perhaps you should add the directory containing `iconv.pc'
to the PKG_CONFIG_PATH environment variable
Package 'iconv', required by 'libarchive', not found
Fixes:
- http://autobuild.buildroot.org/results/05a5496495e51da2c9caf7570695cc95e1745e30
- http://autobuild.buildroot.org/results/98dc4b415115cca65b53e4cd986144ef85bf17ad
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
e8e461bba5
commit
1e8cce6f2b
@ -1,44 +0,0 @@
|
||||
From 1f35c466aaa9444335a1b854b0b7223b0d2346c2 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Pentchev <roam@ringlet.net>
|
||||
Date: Thu, 29 Dec 2022 00:04:40 +0200
|
||||
Subject: [PATCH] Only add "iconv" to the .pc file if needed (#1825)
|
||||
|
||||
Hi,
|
||||
|
||||
Thanks for writing and maintaining libarchive!
|
||||
|
||||
What do you think about this trivial change that does not add "iconv" to
|
||||
the pkg-config file's list of required packages unless it is actually
|
||||
needed? On at least Debian GNU/Linux systems, the iconv(3) function is
|
||||
part of the system C library and there is no Debian package that
|
||||
installs an iconv.pc file, so I had to make this change to the Debian
|
||||
package of libarchive.
|
||||
|
||||
Thanks again, and keep up the great work!
|
||||
|
||||
G'luck,
|
||||
Peter
|
||||
|
||||
Downloaded from upstream commit:
|
||||
https://github.com/libarchive/libarchive/commit/1f35c466aaa9444335a1b854b0b7223b0d2346c2
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
---
|
||||
configure.ac | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 99bff20d1..e2715cfde 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -378,7 +378,9 @@ if test "x$with_iconv" != "xno"; then
|
||||
AC_CHECK_HEADERS([localcharset.h])
|
||||
am_save_LIBS="$LIBS"
|
||||
LIBS="${LIBS} ${LIBICONV}"
|
||||
- LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
|
||||
+ if test -n "$LIBICONV"; then
|
||||
+ LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
|
||||
+ fi
|
||||
AC_CHECK_FUNCS([locale_charset])
|
||||
LIBS="${am_save_LIBS}"
|
||||
if test "x$ac_cv_func_locale_charset" != "xyes"; then
|
@ -0,0 +1,28 @@
|
||||
From 619c1be8d38ff79622db8f66f3b02832795315f9 Mon Sep 17 00:00:00 2001
|
||||
From: Christian Hesse <mail@eworm.de>
|
||||
Date: Wed, 14 Dec 2022 09:04:39 +0100
|
||||
Subject: [PATCH] autotools: do not add iconv for Requires.private
|
||||
|
||||
There is no pkgconfig file for iconv, thus things break with this
|
||||
change. Let's drop iconv from Requires.private.
|
||||
|
||||
Fixes: a83f3d32 ("autotools: Fix static linking when openssl is enabled in windows")
|
||||
[Retrieved from:
|
||||
https://github.com/libarchive/libarchive/pull/1817/commits/619c1be8d38ff79622db8f66f3b02832795315f9]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
configure.ac | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 99bff20d1..f245d0c55 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -378,7 +378,6 @@ if test "x$with_iconv" != "xno"; then
|
||||
AC_CHECK_HEADERS([localcharset.h])
|
||||
am_save_LIBS="$LIBS"
|
||||
LIBS="${LIBS} ${LIBICONV}"
|
||||
- LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
|
||||
AC_CHECK_FUNCS([locale_charset])
|
||||
LIBS="${am_save_LIBS}"
|
||||
if test "x$ac_cv_func_locale_charset" != "xyes"; then
|
Loading…
Reference in New Issue
Block a user