63c735b60a
The different patches are just refreshed to apply without fuzz, there are no changes/conflicts. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
24 lines
1.0 KiB
Diff
24 lines
1.0 KiB
Diff
Don't look in /usr/lib/termcap for libraries
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
|
|
Index: b/setup.py
|
|
===================================================================
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -762,12 +762,9 @@
|
|
pass # Issue 7384: Already linked against curses or tinfo.
|
|
elif curses_library:
|
|
readline_libs.append(curses_library)
|
|
- elif self.compiler.find_library_file(lib_dirs +
|
|
- ['/usr/lib/termcap'],
|
|
- 'termcap'):
|
|
+ elif self.compiler.find_library_file(lib_dirs, 'termcap'):
|
|
readline_libs.append('termcap')
|
|
exts.append( Extension('readline', ['readline.c'],
|
|
- library_dirs=['/usr/lib/termcap'],
|
|
extra_link_args=readline_extra_link_args,
|
|
libraries=readline_libs) )
|
|
else:
|