python: bump to version 2.7.8
The different patches are just refreshed to apply without fuzz, there are no changes/conflicts. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
9fa9cf998e
commit
63c735b60a
@ -52,7 +52,7 @@ Index: b/Makefile.pre.in
|
||||
@for d in $(LIBSUBDIRS); \
|
||||
do \
|
||||
a=$(srcdir)/Lib/$$d; \
|
||||
@@ -1303,7 +1311,7 @@
|
||||
@@ -1304,7 +1312,7 @@
|
||||
Modules/Setup Modules/Setup.local Modules/Setup.config \
|
||||
Modules/ld_so_aix Modules/python.exp Misc/python.pc
|
||||
-rm -f python*-gdb.py
|
||||
|
@ -2,7 +2,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -3330,7 +3330,7 @@
|
||||
@@ -3343,7 +3343,7 @@
|
||||
|
||||
AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
|
||||
|
||||
|
@ -33,7 +33,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2268,6 +2268,8 @@
|
||||
@@ -2281,6 +2281,8 @@
|
||||
|
||||
AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
|
||||
|
||||
|
@ -7,7 +7,7 @@ Index: b/setup.py
|
||||
===================================================================
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -760,12 +760,9 @@
|
||||
@@ -762,12 +762,9 @@
|
||||
pass # Issue 7384: Already linked against curses or tinfo.
|
||||
elif curses_library:
|
||||
readline_libs.append(curses_library)
|
||||
|
@ -26,7 +26,7 @@ Index: b/configure.ac
|
||||
case $ac_sys_system in
|
||||
CYGWIN*)
|
||||
BLDLIBRARY='$(LIBRARY)'
|
||||
@@ -1909,6 +1911,9 @@
|
||||
@@ -1915,6 +1917,9 @@
|
||||
AC_SUBST(BLDSHARED)
|
||||
AC_SUBST(CCSHARED)
|
||||
AC_SUBST(LINKFORSHARED)
|
||||
@ -36,7 +36,7 @@ Index: b/configure.ac
|
||||
# SO is the extension of shared libraries `(including the dot!)
|
||||
# -- usually .so, .sl on HP-UX, .dll on Cygwin
|
||||
AC_MSG_CHECKING(SO)
|
||||
@@ -4550,7 +4555,7 @@
|
||||
@@ -4563,7 +4568,7 @@
|
||||
AC_MSG_RESULT(done)
|
||||
|
||||
# generate output files
|
||||
@ -91,7 +91,7 @@ Index: b/Makefile.pre.in
|
||||
@if [ -s Modules/python.exp -a \
|
||||
"`echo $(MACHDEP) | sed 's/^\(...\).*/\1/'`" = "aix" ]; then \
|
||||
echo; echo "Installing support files for building shared extension modules on AIX:"; \
|
||||
@@ -1311,6 +1313,7 @@
|
||||
@@ -1312,6 +1314,7 @@
|
||||
config.cache config.log pyconfig.h Modules/config.c
|
||||
-rm -rf build platform
|
||||
-rm -rf $(PYTHONFRAMEWORKDIR)
|
||||
|
@ -78,7 +78,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2612,6 +2612,12 @@
|
||||
@@ -2625,6 +2625,12 @@
|
||||
fi
|
||||
|
||||
|
||||
|
@ -40,7 +40,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2611,6 +2611,11 @@
|
||||
@@ -2624,6 +2624,11 @@
|
||||
AC_CHECK_FUNCS(pthread_atfork)
|
||||
fi
|
||||
|
||||
@ -56,7 +56,7 @@ Index: b/setup.py
|
||||
===================================================================
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -2217,6 +2217,12 @@
|
||||
@@ -2219,6 +2219,12 @@
|
||||
# turn off warnings when deprecated modules are imported
|
||||
import warnings
|
||||
warnings.filterwarnings("ignore",category=DeprecationWarning)
|
||||
@ -69,7 +69,7 @@ Index: b/setup.py
|
||||
setup(# PyPI Metadata (PEP 301)
|
||||
name = "Python",
|
||||
version = sys.version.split()[0],
|
||||
@@ -2237,9 +2243,7 @@
|
||||
@@ -2239,9 +2245,7 @@
|
||||
ext_modules=[Extension('_struct', ['_struct.c'])],
|
||||
|
||||
# Scripts to install
|
||||
|
@ -52,7 +52,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2623,6 +2623,12 @@
|
||||
@@ -2636,6 +2636,12 @@
|
||||
AS_HELP_STRING([--disable-test-modules], [disable test modules]),
|
||||
[ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
|
||||
|
||||
@ -69,7 +69,7 @@ Index: b/setup.py
|
||||
===================================================================
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -2218,10 +2218,11 @@
|
||||
@@ -2220,10 +2220,11 @@
|
||||
import warnings
|
||||
warnings.filterwarnings("ignore",category=DeprecationWarning)
|
||||
|
||||
|
@ -12,7 +12,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2611,6 +2611,15 @@
|
||||
@@ -2624,6 +2624,15 @@
|
||||
AC_CHECK_FUNCS(pthread_atfork)
|
||||
fi
|
||||
|
||||
|
@ -48,7 +48,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2620,6 +2620,15 @@
|
||||
@@ -2633,6 +2633,15 @@
|
||||
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
|
||||
fi
|
||||
|
||||
|
@ -36,7 +36,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2629,6 +2629,15 @@
|
||||
@@ -2642,6 +2642,15 @@
|
||||
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
|
||||
fi
|
||||
|
||||
|
@ -43,7 +43,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2276,13 +2276,21 @@
|
||||
@@ -2289,13 +2289,21 @@
|
||||
AC_SUBST(DISABLED_EXTENSIONS)
|
||||
|
||||
# Check for use of the system expat library
|
||||
@ -74,7 +74,7 @@ Index: b/setup.py
|
||||
===================================================================
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -1469,7 +1469,7 @@
|
||||
@@ -1471,7 +1471,7 @@
|
||||
#
|
||||
# More information on Expat can be found at www.libexpat.org.
|
||||
#
|
||||
|
@ -10,7 +10,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2628,6 +2628,12 @@
|
||||
@@ -2641,6 +2641,12 @@
|
||||
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
|
||||
fi
|
||||
|
||||
|
@ -13,7 +13,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2634,6 +2634,12 @@
|
||||
@@ -2647,6 +2647,12 @@
|
||||
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _codecs_kr _codecs_jp _codecs_cn _codecs_tw _codecs_hk"
|
||||
fi])
|
||||
|
||||
|
@ -10,7 +10,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2640,6 +2640,12 @@
|
||||
@@ -2653,6 +2653,12 @@
|
||||
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
|
||||
fi])
|
||||
|
||||
|
@ -49,7 +49,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2640,6 +2640,28 @@
|
||||
@@ -2653,6 +2653,28 @@
|
||||
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
|
||||
fi])
|
||||
|
||||
|
@ -10,7 +10,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2640,6 +2640,12 @@
|
||||
@@ -2653,6 +2653,12 @@
|
||||
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
|
||||
fi])
|
||||
|
||||
|
@ -9,7 +9,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2646,6 +2646,12 @@
|
||||
@@ -2659,6 +2659,12 @@
|
||||
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl"
|
||||
fi])
|
||||
|
||||
|
@ -9,7 +9,7 @@ Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2652,6 +2652,12 @@
|
||||
@@ -2665,6 +2665,12 @@
|
||||
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} bz2"
|
||||
fi])
|
||||
|
||||
|
@ -32,7 +32,7 @@ Index: b/setup.py
|
||||
===================================================================
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -2218,7 +2218,7 @@
|
||||
@@ -2220,7 +2220,7 @@
|
||||
import warnings
|
||||
warnings.filterwarnings("ignore",category=DeprecationWarning)
|
||||
|
||||
|
@ -5,7 +5,7 @@
|
||||
################################################################################
|
||||
|
||||
PYTHON_VERSION_MAJOR = 2.7
|
||||
PYTHON_VERSION = $(PYTHON_VERSION_MAJOR).7
|
||||
PYTHON_VERSION = $(PYTHON_VERSION_MAJOR).8
|
||||
PYTHON_SOURCE = Python-$(PYTHON_VERSION).tar.xz
|
||||
PYTHON_SITE = http://python.org/ftp/python/$(PYTHON_VERSION)
|
||||
PYTHON_LICENSE = Python software foundation license v2, others
|
||||
|
Loading…
Reference in New Issue
Block a user