13c7db8716
When building on Aarch64 host for powerpc64 we get this error: gcc: error: unrecognized command-line option '-m64' This happens because we don't have the flexibility to override the LDFLAGS when linking nsinstall host tool that is built in libnss. Also libnss uses the same LDFLAGS it uses for target and that is not correct. So let's add a patch to add NATIVE_LDFLAGS variable to override LFDFLAGS when building nsinstall utility and set it to HOST_LDFLAGS in libnss.mk Fixes: http://autobuild.buildroot.net/results/67500395f19aa698b98404cde8d20463e55504bf/ Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com> Tested-by: James Hilliard <james.hilliard1@gmail.com> [yann.morin.1998@free.fr: add upstream link in patch itself] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
38 lines
1.2 KiB
Diff
38 lines
1.2 KiB
Diff
From 9d5900c1ee9000906a90923e861b0fd7f1061cde Mon Sep 17 00:00:00 2001
|
|
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
|
Date: Tue, 24 May 2022 23:40:45 +0200
|
|
Subject: [PATCH] Bug 1771036 - Fix build failure on Aarch64 host
|
|
|
|
If trying to build on Aarch64 host for powerpc64 target we can't override
|
|
the LDFLAGS leading to this build failure:
|
|
gcc: error: unrecognized command-line option '-m64'
|
|
|
|
So let's add NATIVE_LDFLAGS check and use it to link nsinstall. This way
|
|
any build environment can pass LDFLAGS that fits better for host
|
|
architecture.
|
|
|
|
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
|
[upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1771036]
|
|
---
|
|
coreconf/nsinstall/Makefile | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/nss/coreconf/nsinstall/Makefile b/nss/coreconf/nsinstall/Makefile
|
|
index 08dfbc2fe..5061789ff 100644
|
|
--- a/nss/coreconf/nsinstall/Makefile
|
|
+++ b/nss/coreconf/nsinstall/Makefile
|
|
@@ -34,6 +34,10 @@ ifdef NATIVE_FLAGS
|
|
OS_CFLAGS=$(NATIVE_FLAGS)
|
|
endif
|
|
|
|
+ifdef NATIVE_LDFLAGS
|
|
+LDFLAGS=$(NATIVE_LDFLAGS)
|
|
+endif
|
|
+
|
|
include $(DEPTH)/coreconf/rules.mk
|
|
|
|
# Redefine MAKE_OBJDIR for just this directory
|
|
--
|
|
2.34.1
|
|
|