package/libnss: fix build failure on Aarch64 host for powerpc64 target

When building on Aarch64 host for powerpc64 we get this error:
gcc: error: unrecognized command-line option '-m64'

This happens because we don't have the flexibility to override the LDFLAGS
when linking nsinstall host tool that is built in libnss. Also libnss uses
the same LDFLAGS it uses for target and that is not correct.
So let's add a patch to add NATIVE_LDFLAGS variable to override LFDFLAGS
when building nsinstall utility and set it to HOST_LDFLAGS in libnss.mk

Fixes:
http://autobuild.buildroot.net/results/67500395f19aa698b98404cde8d20463e55504bf/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Tested-by: James Hilliard <james.hilliard1@gmail.com>
[yann.morin.1998@free.fr: add upstream link in patch itself]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Giulio Benetti 2022-05-25 00:07:34 +02:00 committed by Yann E. MORIN
parent 4245bc29d4
commit 13c7db8716
2 changed files with 40 additions and 1 deletions

View File

@ -0,0 +1,37 @@
From 9d5900c1ee9000906a90923e861b0fd7f1061cde Mon Sep 17 00:00:00 2001
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
Date: Tue, 24 May 2022 23:40:45 +0200
Subject: [PATCH] Bug 1771036 - Fix build failure on Aarch64 host
If trying to build on Aarch64 host for powerpc64 target we can't override
the LDFLAGS leading to this build failure:
gcc: error: unrecognized command-line option '-m64'
So let's add NATIVE_LDFLAGS check and use it to link nsinstall. This way
any build environment can pass LDFLAGS that fits better for host
architecture.
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
[upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1771036]
---
coreconf/nsinstall/Makefile | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/nss/coreconf/nsinstall/Makefile b/nss/coreconf/nsinstall/Makefile
index 08dfbc2fe..5061789ff 100644
--- a/nss/coreconf/nsinstall/Makefile
+++ b/nss/coreconf/nsinstall/Makefile
@@ -34,6 +34,10 @@ ifdef NATIVE_FLAGS
OS_CFLAGS=$(NATIVE_FLAGS)
endif
+ifdef NATIVE_LDFLAGS
+LDFLAGS=$(NATIVE_LDFLAGS)
+endif
+
include $(DEPTH)/coreconf/rules.mk
# Redefine MAKE_OBJDIR for just this directory
--
2.34.1

View File

@ -92,7 +92,9 @@ define LIBNSS_BUILD_CMDS
SOURCE_MD_DIR=$(@D)/$(LIBNSS_DISTDIR) \
DIST=$(@D)/$(LIBNSS_DISTDIR) \
CHECKLOC= \
$(LIBNSS_BUILD_VARS) NATIVE_FLAGS="$(HOST_CFLAGS) -DLINUX"
$(LIBNSS_BUILD_VARS) \
NATIVE_FLAGS="$(HOST_CFLAGS) -DLINUX" \
NATIVE_LDFLAGS="$(HOST_LDFLAGS)"
endef
define LIBNSS_INSTALL_STAGING_CMDS