kumquat-buildroot/package/gensio/0001-tests-Makefile-am-don-t-add-lpthread.patch
Fabrice Fontaine 5349c37e72 package/gensio: bump to version 1.5.1
- Update indentation of hash file (2 spaces)
- This will fix a build failure without threads thanks to
  8918de5b30
  and associated upstream patch

Fixes:
 - http://autobuild.buildroot.org/results/e94d0e0b46afc1223a74bcc471909f4adef0d6f3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2020-02-16 15:22:26 +01:00

30 lines
1.0 KiB
Diff

From f63b15e690581d898da56ef2540b6199f5728e58 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Tue, 11 Feb 2020 19:14:53 +0100
Subject: [PATCH] tests/Makefile.am: don't add -lpthread
Don't add -lpthread unconditionally to oomtest_LDADD to avoid a build
failure without threads, it will be added to LIBS by configure.ac if
needed
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Retrieved from:
https://github.com/cminyard/gensio/commit/f63b15e690581d898da56ef2540b6199f5728e58]
---
tests/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a280acc..b4335c5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -127,7 +127,7 @@ test_fuzz: test_fuzz_certauth test_fuzz_mux test_fuzz_ssl test_fuzz_telnet \
oomtest_SOURCES = oomtest.c
-oomtest_LDADD = $(top_builddir)/lib/libgensio.la $(OPENSSL_LIBS) -lpthread
+oomtest_LDADD = $(top_builddir)/lib/libgensio.la $(OPENSSL_LIBS)
noinst_PROGRAMS = oomtest