package/gensio: bump to version 1.5.1

- Update indentation of hash file (2 spaces)
- This will fix a build failure without threads thanks to
  8918de5b30
  and associated upstream patch

Fixes:
 - http://autobuild.buildroot.org/results/e94d0e0b46afc1223a74bcc471909f4adef0d6f3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Fabrice Fontaine 2020-02-12 19:06:53 +01:00 committed by Peter Korsgaard
parent cc0c9915db
commit 5349c37e72
3 changed files with 39 additions and 8 deletions

View File

@ -0,0 +1,29 @@
From f63b15e690581d898da56ef2540b6199f5728e58 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Tue, 11 Feb 2020 19:14:53 +0100
Subject: [PATCH] tests/Makefile.am: don't add -lpthread
Don't add -lpthread unconditionally to oomtest_LDADD to avoid a build
failure without threads, it will be added to LIBS by configure.ac if
needed
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Retrieved from:
https://github.com/cminyard/gensio/commit/f63b15e690581d898da56ef2540b6199f5728e58]
---
tests/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a280acc..b4335c5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -127,7 +127,7 @@ test_fuzz: test_fuzz_certauth test_fuzz_mux test_fuzz_ssl test_fuzz_telnet \
oomtest_SOURCES = oomtest.c
-oomtest_LDADD = $(top_builddir)/lib/libgensio.la $(OPENSSL_LIBS) -lpthread
+oomtest_LDADD = $(top_builddir)/lib/libgensio.la $(OPENSSL_LIBS)
noinst_PROGRAMS = oomtest

View File

@ -1,7 +1,7 @@
# From https://sourceforge.net/projects/ser2net/files/
md5 3a84895e41b9ca85801d2d5727977356 gensio-1.4.1.tar.gz
sha1 3b268b7c37edabd87547f98d03ecf4929f3e5381 gensio-1.4.1.tar.gz
# From https://sourceforge.net/projects/ser2net/files/ser2net/
md5 53c027dfaaf374f57d5f36a6250fc018 gensio-1.5.1.tar.gz
sha1 8329d7828016e643f60b8b3e70564d32cd03008f gensio-1.5.1.tar.gz
# Locally computed:
sha256 a0608921c6ccec115a1298d02423b9d8482b444f5772d8a8fde7ceabbadd679a gensio-1.4.1.tar.gz
sha256 501f3108e6c03e5a0a5585ebaaa369171aead5319cd0a7a4dc1f66211c1f09f1 COPYING
sha256 dcac7d447dd81ab96d28dce00a07a6486e623f7ded94e2a2a8e83312405cdf89 COPYING.LIB
sha256 c1ed28f5bd72185dba666a900d29afbecba58727d6c0dde4a182143273fc1e6b gensio-1.5.1.tar.gz
sha256 501f3108e6c03e5a0a5585ebaaa369171aead5319cd0a7a4dc1f66211c1f09f1 COPYING
sha256 dcac7d447dd81ab96d28dce00a07a6486e623f7ded94e2a2a8e83312405cdf89 COPYING.LIB

View File

@ -4,11 +4,13 @@
#
################################################################################
GENSIO_VERSION = 1.4.1
GENSIO_SITE = http://downloads.sourceforge.net/project/ser2net
GENSIO_VERSION = 1.5.1
GENSIO_SITE = http://downloads.sourceforge.net/project/ser2net/ser2net
GENSIO_LICENSE = LGPL-2.1+ (library), GPL-2.0+ (tools)
GENSIO_LICENSE_FILES = COPYING.LIB COPYING
GENSIO_INSTALL_STAGING = YES
# We're patching configure.ac
GENSIO_AUTORECONF = YES
GENSIO_CONF_OPTS = \
--without-openipmi \
--without-swig \