83114f4552
Switch to github helper while at it. Depend on BR2_ARM_FPU_NEON || BR2_ARM_FPU_NEON_VFPV4 so that the toolchain wrapper will add -mfpu=neon, and avoid the following error: .../include/arm_neon.h:32:2: error: #error You must enable NEON instructions (e.g. -mfloat-abi=softfp -mfpu=neon) to use arm_neon.h Note that this error doesn't show in the build-end.log referenced below because of the log lines limit. Fixes: http://autobuild.buildroot.net/results/a2c/a2ca3fe245e410a738f4b10631a1414696a0edea/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
28 lines
1020 B
Diff
28 lines
1020 B
Diff
From 00995e0b8a66fbd0eabd206188120bfc1ecdac59 Mon Sep 17 00:00:00 2001
|
|
Message-Id: <00995e0b8a66fbd0eabd206188120bfc1ecdac59.1398245232.git.baruch@tkos.co.il>
|
|
From: Baruch Siach <baruch@tkos.co.il>
|
|
Date: Wed, 23 Apr 2014 12:21:37 +0300
|
|
Subject: [PATCH] CMakeLists: don't hard code thumb code generation
|
|
|
|
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
|
---
|
|
CMakeLists.txt | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 2c7f8d62a42b..cec614fba041 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -77,7 +77,7 @@ if(ANDROID_PLATFORM)
|
|
add_subdirectory(android/NE10Demo/jni)
|
|
endif()
|
|
elseif(GNULINUX_PLATFORM)
|
|
- set(CMAKE_C_FLAGS "-O2 -mthumb-interwork -mthumb -march=armv7-a -mfpu=vfp3")
|
|
+ set(CMAKE_C_FLAGS "-O2 -mthumb-interwork -march=armv7-a -mfpu=vfp3")
|
|
set(CMAKE_ASM_FLAGS "-mthumb-interwork -mthumb -march=armv7-a -mfpu=neon")
|
|
elseif(IOS_PLATFORM)
|
|
#set minimal target ios version.If not provided this option, Xcode
|
|
--
|
|
1.9.2
|
|
|