ne10: bump version to 1.0.0
Switch to github helper while at it. Depend on BR2_ARM_FPU_NEON || BR2_ARM_FPU_NEON_VFPV4 so that the toolchain wrapper will add -mfpu=neon, and avoid the following error: .../include/arm_neon.h:32:2: error: #error You must enable NEON instructions (e.g. -mfloat-abi=softfp -mfpu=neon) to use arm_neon.h Note that this error doesn't show in the build-end.log referenced below because of the log lines limit. Fixes: http://autobuild.buildroot.net/results/a2c/a2ca3fe245e410a738f4b10631a1414696a0edea/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
ec6aaa4706
commit
83114f4552
@ -1,6 +1,7 @@
|
||||
config BR2_PACKAGE_NE10
|
||||
bool "ne10"
|
||||
depends on BR2_arm && BR2_ARM_CPU_HAS_NEON
|
||||
depends on BR2_arm
|
||||
depends on BR2_ARM_FPU_NEON || BR2_ARM_FPU_NEON_VFPV4
|
||||
help
|
||||
The Ne10 project has been set up to provide a set of common,
|
||||
useful functions which have been heavily optimized for the
|
||||
@ -10,3 +11,7 @@ config BR2_PACKAGE_NE10
|
||||
and NEON implementations.
|
||||
|
||||
http://projectne10.github.io/Ne10/
|
||||
|
||||
comment "ne10 needs a toolchain w/ neon"
|
||||
depends on BR2_arm
|
||||
depends on !(BR2_ARM_FPU_NEON || BR2_ARM_FPU_NEON_VFPV4)
|
||||
|
@ -0,0 +1,27 @@
|
||||
From 00995e0b8a66fbd0eabd206188120bfc1ecdac59 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <00995e0b8a66fbd0eabd206188120bfc1ecdac59.1398245232.git.baruch@tkos.co.il>
|
||||
From: Baruch Siach <baruch@tkos.co.il>
|
||||
Date: Wed, 23 Apr 2014 12:21:37 +0300
|
||||
Subject: [PATCH] CMakeLists: don't hard code thumb code generation
|
||||
|
||||
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 2c7f8d62a42b..cec614fba041 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -77,7 +77,7 @@ if(ANDROID_PLATFORM)
|
||||
add_subdirectory(android/NE10Demo/jni)
|
||||
endif()
|
||||
elseif(GNULINUX_PLATFORM)
|
||||
- set(CMAKE_C_FLAGS "-O2 -mthumb-interwork -mthumb -march=armv7-a -mfpu=vfp3")
|
||||
+ set(CMAKE_C_FLAGS "-O2 -mthumb-interwork -march=armv7-a -mfpu=vfp3")
|
||||
set(CMAKE_ASM_FLAGS "-mthumb-interwork -mthumb -march=armv7-a -mfpu=neon")
|
||||
elseif(IOS_PLATFORM)
|
||||
#set minimal target ios version.If not provided this option, Xcode
|
||||
--
|
||||
1.9.2
|
||||
|
@ -4,15 +4,15 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
# We use a Git commit ID because the last tagged version is more than
|
||||
# one year old.
|
||||
NE10_VERSION = 88c18f02199947b2c8b57796f5a3ca53160aff96
|
||||
NE10_SITE = http://github.com/projectNe10/Ne10/tarball/$(NE10_VERSION)
|
||||
NE10_VERSION = v1.0.0
|
||||
NE10_SITE = $(call github,projectNe10,Ne10,$(NE10_VERSION))
|
||||
NE10_LICENSE = BSD-3c or Apache-2.0
|
||||
NE10_LICENSE_FILES = doc/LICENSE
|
||||
|
||||
NE10_CONF_OPT = -DGNULINUX_PLATFORM=ON
|
||||
|
||||
ifeq ($(BR2_PREFER_STATIC_LIB),)
|
||||
NE10_CONF_OPT = \
|
||||
NE10_CONF_OPT += \
|
||||
-DNE10_BUILD_SHARED=ON
|
||||
endif
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user