kumquat-buildroot/package/perl-net-ssleay/0001-fix-build-system.patch
Fabrice Fontaine 191fa1718f package/perl-net-ssleay: bump to version 1.93_01
- Refresh patch
- Drop -lz from Makefile with libressl as this is the only solution for
  now: https://github.com/radiator-software/p5-net-ssleay/issues/399
- License has been clarified to be Artistic-2.0 since version 1.86.11:
  aa4a0206d6
- This bump will fix the following build failure with libressl:

  In file included from /home/autobuild/autobuild/instance-11/output-1/host/armeb-buildroot-linux-uclibcgnueabi/sysroot/usr/lib/perl5/5.34.1/armeb-linux/CORE/perl.h:5748,
                   from SSLeay.xs:141:
  SSLeay.xs: In function 'XS_Net__SSLeay_SESSION_get_master_key':
  SSLeay.xs:5569:37: error: invalid use of incomplete typedef 'SSL_SESSION' {aka 'struct ssl_session_st'}
   5569 |      sv_setpvn(ST(0), (const char*)s->master_key, s->master_key_length);
        |                                     ^~

https://metacpan.org/release/CHRISN/Net-SSLeay-1.93_01/changes

Fixes:
 - http://autobuild.buildroot.org/results/71337cc496727f2b1173c055d706c5bfc2f5d2bc

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2022-11-13 22:52:15 +01:00

37 lines
1.7 KiB
Diff

buildsystem: fix for cross-compilation
Avoid running the openssl binary, since it would break for
cross-compilation. Buildroot has a supported version, anyway.
Also, avoid adding hard-coded includes and libraries search
paths, since they are missing the destdir; Buildroot compilers
and linkers already know where to search, anyway.
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[Fabrice: update for 1.93_01]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
diff -durN perl-net-ssleay-1.64.orig/inc/Module/Install/PRIVATE/Net/SSLeay.pm perl-net-ssleay-1.64/inc/Module/Install/PRIVATE/Net/SSLeay.pm
--- perl-net-ssleay-1.64.orig/Makefile.PL 2014-04-01 08:08:37.000000000 +0200
+++ perl-net-ssleay-1.64/Makefile.PL 2014-07-13 00:38:46.281380282 +0200
@@ -192,12 +192,16 @@
exit MISSING_PREREQ;
}
- check_openssl_version($prefix, $exec);
+# Does not work for cross-compilation.
+# In Buildroot, we do have a supported version.
+# check_openssl_version($prefix, $exec);
my %args = (
CCCDLFLAGS => $opts->{cccdlflags},
OPTIMIZE => $opts->{optimize},
- INC => qq{-I"$opts->{inc_path}"},
- LIBS => join(' ', (map '-L'.maybe_quote($_), @{$opts->{lib_paths}}), (map {"-l$_"} @{$opts->{lib_links}})),
+# Buildroot already has the correct include and library search paths.
+# INC => qq{-I"$opts->{inc_path}"},
+# LIBS => join(' ', (map '-L'.maybe_quote($_), @{$opts->{lib_paths}}), (map {"-l$_"} @{$opts->{lib_links}})),
+ LIBS => join(' ', (map {"-l$_"} @{$opts->{lib_links}})),
);
# From HMBRAND to handle multple version of OPENSSL installed
if (my $lp = join " " => map '-L'.maybe_quote($_), @{$opts->{lib_paths} || []})