package/perl-net-ssleay: bump to version 1.93_01
- Refresh patch
- Drop -lz from Makefile with libressl as this is the only solution for
now: https://github.com/radiator-software/p5-net-ssleay/issues/399
- License has been clarified to be Artistic-2.0 since version 1.86.11:
aa4a0206d6
- This bump will fix the following build failure with libressl:
In file included from /home/autobuild/autobuild/instance-11/output-1/host/armeb-buildroot-linux-uclibcgnueabi/sysroot/usr/lib/perl5/5.34.1/armeb-linux/CORE/perl.h:5748,
from SSLeay.xs:141:
SSLeay.xs: In function 'XS_Net__SSLeay_SESSION_get_master_key':
SSLeay.xs:5569:37: error: invalid use of incomplete typedef 'SSL_SESSION' {aka 'struct ssl_session_st'}
5569 | sv_setpvn(ST(0), (const char*)s->master_key, s->master_key_length);
| ^~
https://metacpan.org/release/CHRISN/Net-SSLeay-1.93_01/changes
Fixes:
- http://autobuild.buildroot.org/results/71337cc496727f2b1173c055d706c5bfc2f5d2bc
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
a0aad05cbf
commit
191fa1718f
@ -8,29 +8,29 @@ paths, since they are missing the destdir; Buildroot compilers
|
||||
and linkers already know where to search, anyway.
|
||||
|
||||
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
||||
[Fabrice: update for 1.93_01]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
|
||||
diff -durN perl-net-ssleay-1.64.orig/inc/Module/Install/PRIVATE/Net/SSLeay.pm perl-net-ssleay-1.64/inc/Module/Install/PRIVATE/Net/SSLeay.pm
|
||||
--- perl-net-ssleay-1.64.orig/inc/Module/Install/PRIVATE/Net/SSLeay.pm 2014-04-01 08:08:37.000000000 +0200
|
||||
+++ perl-net-ssleay-1.64/inc/Module/Install/PRIVATE/Net/SSLeay.pm 2014-07-13 00:38:46.281380282 +0200
|
||||
@@ -37,14 +37,18 @@
|
||||
exit 0; # according http://wiki.cpantesters.org/wiki/CPANAuthorNotes this is best-practice when "missing library"
|
||||
--- perl-net-ssleay-1.64.orig/Makefile.PL 2014-04-01 08:08:37.000000000 +0200
|
||||
+++ perl-net-ssleay-1.64/Makefile.PL 2014-07-13 00:38:46.281380282 +0200
|
||||
@@ -192,12 +192,16 @@
|
||||
exit MISSING_PREREQ;
|
||||
}
|
||||
|
||||
- $self->check_openssl_version($prefix, $exec);
|
||||
- check_openssl_version($prefix, $exec);
|
||||
+# Does not work for cross-compilation.
|
||||
+# In Buildroot, we do have a supported version.
|
||||
+# $self->check_openssl_version($prefix, $exec);
|
||||
my $opts = $self->ssleay_get_build_opts($prefix, $exec);
|
||||
|
||||
$self->makemaker_args(
|
||||
+# check_openssl_version($prefix, $exec);
|
||||
my %args = (
|
||||
CCCDLFLAGS => $opts->{cccdlflags},
|
||||
OPTIMIZE => $opts->{optimize},
|
||||
- INC => join(' ', map {"-I$_"} @{$opts->{inc_paths}}),
|
||||
- LIBS => join(' ', (map {"-L$_"} @{$opts->{lib_paths}}), (map {"-l$_"} @{$opts->{lib_links}})),
|
||||
- INC => qq{-I"$opts->{inc_path}"},
|
||||
- LIBS => join(' ', (map '-L'.maybe_quote($_), @{$opts->{lib_paths}}), (map {"-l$_"} @{$opts->{lib_links}})),
|
||||
+# Buildroot already has the correct include and library search paths.
|
||||
+# INC => join(' ', map {"-I$_"} @{$opts->{inc_paths}}),
|
||||
+# LIBS => join(' ', (map {"-L$_"} @{$opts->{lib_paths}}), (map {"-l$_"} @{$opts->{lib_links}})),
|
||||
+# INC => qq{-I"$opts->{inc_path}"},
|
||||
+# LIBS => join(' ', (map '-L'.maybe_quote($_), @{$opts->{lib_paths}}), (map {"-l$_"} @{$opts->{lib_links}})),
|
||||
+ LIBS => join(' ', (map {"-l$_"} @{$opts->{lib_links}})),
|
||||
);
|
||||
|
||||
if ( $self->prompt(
|
||||
# From HMBRAND to handle multple version of OPENSSL installed
|
||||
if (my $lp = join " " => map '-L'.maybe_quote($_), @{$opts->{lib_paths} || []})
|
||||
|
@ -1,6 +1,6 @@
|
||||
# retrieved by scancpan from http://cpan.metacpan.org/
|
||||
md5 d602bdce4e0531c6efc276e3e429ca69 Net-SSLeay-1.85.tar.gz
|
||||
sha256 9d8188b9fb1cae3bd791979c20554925d5e94a138d00414f1a6814549927b0c8 Net-SSLeay-1.85.tar.gz
|
||||
md5 c73821e9790b3bdb3471d9b8faf48bbb Net-SSLeay-1.93_01.tar.gz
|
||||
sha256 876d022fbc719631b11d6bb4b6e78db3c19bbca578093c376c8f9900a4432aa3 Net-SSLeay-1.93_01.tar.gz
|
||||
|
||||
# computed by scancpan
|
||||
sha256 b55065185a2172d9f2ea2dd87c18c206ea3dc45a64e5f3deb3eee34d839dc822 LICENSE
|
||||
sha256 685e534b60d4e2b4fbb1a259a83b5a86e877a919bbb9efc95994276f706a3a71 LICENSE
|
||||
|
@ -4,11 +4,11 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
PERL_NET_SSLEAY_VERSION = 1.85
|
||||
PERL_NET_SSLEAY_VERSION = 1.93_01
|
||||
PERL_NET_SSLEAY_SOURCE = Net-SSLeay-$(PERL_NET_SSLEAY_VERSION).tar.gz
|
||||
PERL_NET_SSLEAY_SITE = $(BR2_CPAN_MIRROR)/authors/id/M/MI/MIKEM
|
||||
PERL_NET_SSLEAY_SITE = $(BR2_CPAN_MIRROR)/authors/id/C/CH/CHRISN
|
||||
PERL_NET_SSLEAY_DEPENDENCIES = openssl
|
||||
PERL_NET_SSLEAY_LICENSE = OpenSSL
|
||||
PERL_NET_SSLEAY_LICENSE = Artistic-2.0
|
||||
PERL_NET_SSLEAY_LICENSE_FILES = LICENSE
|
||||
PERL_NET_SSLEAY_DISTNAME = Net-SSLeay
|
||||
|
||||
@ -24,4 +24,11 @@ define PERL_NET_SSLEAY_FIX_MAKEFILE
|
||||
endef
|
||||
PERL_NET_SSLEAY_POST_CONFIGURE_HOOKS += PERL_NET_SSLEAY_FIX_MAKEFILE
|
||||
|
||||
ifeq ($(BR2_PACKAGE_LIBRESSL),y)
|
||||
define PERL_NET_SSLEAY_DROP_ZLIB_MAKEFILE
|
||||
$(SED) "s/-lz//" $(@D)/Makefile
|
||||
endef
|
||||
PERL_NET_SSLEAY_POST_CONFIGURE_HOOKS += PERL_NET_SSLEAY_DROP_ZLIB_MAKEFILE
|
||||
endif
|
||||
|
||||
$(eval $(perl-package))
|
||||
|
Loading…
Reference in New Issue
Block a user