63c735b60a
The different patches are just refreshed to apply without fuzz, there are no changes/conflicts. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
44 lines
1.4 KiB
Diff
44 lines
1.4 KiB
Diff
Do not install the idle editor
|
|
|
|
IDLE is the Python IDE built with the tkinter GUI toolkit. Since it's
|
|
highly unlikely to ever be useful in an embedded Linux system
|
|
generated by Buildroot, this patch simply disables the installation of
|
|
idle and the related Python modules. It saves 800 KB-900 KB of
|
|
installed .pyc files.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/Makefile.pre.in
|
|
===================================================================
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -934,7 +934,6 @@
|
|
json \
|
|
logging csv importlib wsgiref \
|
|
ctypes ctypes/macholib \
|
|
- idlelib idlelib/Icons \
|
|
distutils distutils/command \
|
|
multiprocessing multiprocessing/dummy \
|
|
unittest \
|
|
@@ -949,7 +948,6 @@
|
|
email/test email/test/data \
|
|
json/tests \
|
|
ctypes/test \
|
|
- idlelib/idle_test \
|
|
distutils/tests \
|
|
unittest/test
|
|
|
|
Index: b/setup.py
|
|
===================================================================
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -2220,7 +2220,7 @@
|
|
import warnings
|
|
warnings.filterwarnings("ignore",category=DeprecationWarning)
|
|
|
|
- scripts = ['Tools/scripts/idle', 'Lib/smtpd.py']
|
|
+ scripts = ['Lib/smtpd.py']
|
|
if not '--disable-pydoc' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
scripts += [ 'Tools/scripts/pydoc' ]
|
|
if not '--disable-lib2to3' in sysconfig.get_config_var("CONFIG_ARGS"):
|