d66c981aaa
Fixes: http://autobuild.buildroot.net/results/9ca/9cad1cf49ee6b5c58d8260ee33beef2e6c1ada4d/ Signed-off-by: Axel Lin <axel.lin@ingics.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
From 715186bee512f25715e6d1c58ce03cc32e0efae3 Mon Sep 17 00:00:00 2001
|
|
From: Axel Lin <axel.lin@ingics.com>
|
|
Date: Mon, 30 Dec 2013 18:10:03 +0800
|
|
Subject: [PATCH] Link against -lrt for clock_gettime
|
|
|
|
Fix undefined reference to `clock_gettime' error.
|
|
This is required since commit f3e398afc549 "Rewrite cipher benchmark loop.".
|
|
|
|
Below is the build error report:
|
|
http://autobuild.buildroot.net/results/9ca/9cad1cf49ee6b5c58d8260ee33beef2e6c1ada4d/build-end.log
|
|
|
|
Signed-off-by: Axel Lin <axel.lin@ingics.com>
|
|
---
|
|
configure.ac | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 1c456be..aa4c10f 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -49,7 +49,8 @@ AC_CHECK_LIB(uuid, uuid_clear, ,[AC_MSG_ERROR([You need the uuid library.])])
|
|
AC_SUBST(UUID_LIBS, $LIBS)
|
|
LIBS=$saved_LIBS
|
|
|
|
-AC_CHECK_FUNCS([posix_memalign])
|
|
+AC_SEARCH_LIBS([clock_gettime],[rt posix4])
|
|
+AC_CHECK_FUNCS([posix_memalign clock_gettime])
|
|
|
|
if test "x$enable_largefile" = "xno" ; then
|
|
AC_MSG_ERROR([Building with --disable-largefile is not supported, it can cause data corruption.])
|
|
--
|
|
1.8.1.2
|
|
|