cryptsetup: fix build error after bump version
Fixes: http://autobuild.buildroot.net/results/9ca/9cad1cf49ee6b5c58d8260ee33beef2e6c1ada4d/ Signed-off-by: Axel Lin <axel.lin@ingics.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
712ebe8579
commit
d66c981aaa
@ -0,0 +1,33 @@
|
||||
From 715186bee512f25715e6d1c58ce03cc32e0efae3 Mon Sep 17 00:00:00 2001
|
||||
From: Axel Lin <axel.lin@ingics.com>
|
||||
Date: Mon, 30 Dec 2013 18:10:03 +0800
|
||||
Subject: [PATCH] Link against -lrt for clock_gettime
|
||||
|
||||
Fix undefined reference to `clock_gettime' error.
|
||||
This is required since commit f3e398afc549 "Rewrite cipher benchmark loop.".
|
||||
|
||||
Below is the build error report:
|
||||
http://autobuild.buildroot.net/results/9ca/9cad1cf49ee6b5c58d8260ee33beef2e6c1ada4d/build-end.log
|
||||
|
||||
Signed-off-by: Axel Lin <axel.lin@ingics.com>
|
||||
---
|
||||
configure.ac | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 1c456be..aa4c10f 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -49,7 +49,8 @@ AC_CHECK_LIB(uuid, uuid_clear, ,[AC_MSG_ERROR([You need the uuid library.])])
|
||||
AC_SUBST(UUID_LIBS, $LIBS)
|
||||
LIBS=$saved_LIBS
|
||||
|
||||
-AC_CHECK_FUNCS([posix_memalign])
|
||||
+AC_SEARCH_LIBS([clock_gettime],[rt posix4])
|
||||
+AC_CHECK_FUNCS([posix_memalign clock_gettime])
|
||||
|
||||
if test "x$enable_largefile" = "xno" ; then
|
||||
AC_MSG_ERROR([Building with --disable-largefile is not supported, it can cause data corruption.])
|
||||
--
|
||||
1.8.1.2
|
||||
|
18
package/cryptsetup/cryptsetup-0002-mkdir.patch
Normal file
18
package/cryptsetup/cryptsetup-0002-mkdir.patch
Normal file
@ -0,0 +1,18 @@
|
||||
$(mkdir_p) is obsolete for newer automake, use $(MKDIR_P) instead.
|
||||
Upstream should really gettextize with a newer version before packing up.
|
||||
|
||||
[base on a similar patch from Gustavo Zacarias for Linux-PAM-1.1.7]
|
||||
Signed-off-by: Axel Lin <axel.lin@ingics.com>
|
||||
|
||||
diff -Nura cryptsetup-1.6.3.ori/po/Makefile.in.in cryptsetup-1.6.3/po/Makefile.in.in
|
||||
--- cryptsetup-1.6.3.ori/po/Makefile.in.in 2013-12-30 11:53:22.731942516 +0800
|
||||
+++ cryptsetup-1.6.3/po/Makefile.in.in 2014-01-09 09:46:13.594071188 +0800
|
||||
@@ -31,7 +31,7 @@
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
mkinstalldirs = $(SHELL) @install_sh@ -d
|
||||
-mkdir_p = @mkdir_p@
|
||||
+mkdir_p = @MKDIR_P@
|
||||
|
||||
GMSGFMT_ = @GMSGFMT@
|
||||
GMSGFMT_no = @GMSGFMT@
|
@ -13,6 +13,8 @@ CRYPTSETUP_DEPENDENCIES = lvm2 popt e2fsprogs libgcrypt host-pkgconf \
|
||||
CRYPTSETUP_LICENSE = GPLv2+ (programs), LGPLv2.1+ (library)
|
||||
CRYPTSETUP_LICENSE_FILES = COPYING COPYING.LGPL
|
||||
|
||||
CRYPTSETUP_AUTORECONF = YES
|
||||
|
||||
ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
|
||||
CRYPTSETUP_CONF_ENV += LDFLAGS="$(TARGET_LDFLAGS) -lintl"
|
||||
endif
|
||||
|
Loading…
Reference in New Issue
Block a user