6ff3da375b
Adapt patch 0002 and 0003 for version 2019.01. Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
102 lines
3.2 KiB
Diff
102 lines
3.2 KiB
Diff
From 794aeeb82ab7c0304e343499ee5d82c1f1c5c39a Mon Sep 17 00:00:00 2001
|
|
From: Carlos Santos <casantos@datacom.ind.br>
|
|
Date: Sun, 8 May 2016 11:11:39 -0300
|
|
Subject: [PATCH] Make FIT support really optional
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Due to some mistakes in the source code, it was not possible to really
|
|
turn FIT support off. This commit fixes the problem by means of the
|
|
following changes:
|
|
|
|
- Enclose "bootm_host_load_image" and "bootm_host_load_images" between
|
|
checks for CONFIG_FIT_SIGNATURE, in common/bootm.c.
|
|
|
|
- Enclose the declaration of "bootm_host_load_images" between checks for
|
|
CONFIG_FIT_SIGNATURE, in common/bootm.h.
|
|
|
|
- Condition the compilation and linking of fit_common.o fit_image.o
|
|
image-host.o common/image-fit.o to CONFIG_FIT=y, in tools/Makefile.
|
|
|
|
Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
|
|
[fabio: adapt for 2016.07]
|
|
Signed-off-by: Fabio Estevam <festevam@gmail.com>
|
|
[Ricardo: fix conditional compilation and linking of the files mentioned above
|
|
for 2016.07]
|
|
Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
|
|
[Jörg: adapt for 2019.01]
|
|
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
|
|
---
|
|
common/bootm.c | 2 ++
|
|
include/bootm.h | 2 ++
|
|
tools/Makefile | 6 ++----
|
|
3 files changed, 6 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/common/bootm.c b/common/bootm.c
|
|
index 8bf84ebcb7..ecc29fb7b4 100644
|
|
--- a/common/bootm.c
|
|
+++ b/common/bootm.c
|
|
@@ -922,6 +922,7 @@ void memmove_wd(void *to, void *from, size_t len, ulong chunksz)
|
|
memmove(to, from, len);
|
|
}
|
|
|
|
+#if defined(CONFIG_FIT_SIGNATURE)
|
|
static int bootm_host_load_image(const void *fit, int req_image_type)
|
|
{
|
|
const char *fit_uname_config = NULL;
|
|
@@ -986,5 +987,6 @@ int bootm_host_load_images(const void *fit, int cfg_noffset)
|
|
/* Return the first error we found */
|
|
return err;
|
|
}
|
|
+#endif
|
|
|
|
#endif /* ndef USE_HOSTCC */
|
|
diff --git a/include/bootm.h b/include/bootm.h
|
|
index dbd6f49c2d..f5fe9cb2d3 100644
|
|
--- a/include/bootm.h
|
|
+++ b/include/bootm.h
|
|
@@ -42,7 +42,9 @@ void lynxkdi_boot(image_header_t *hdr);
|
|
|
|
boot_os_fn *bootm_os_get_boot_func(int os);
|
|
|
|
+#if defined(CONFIG_FIT_SIGNATURE)
|
|
int bootm_host_load_images(const void *fit, int cfg_noffset);
|
|
+#endif
|
|
|
|
int boot_selected_os(int argc, char * const argv[], int state,
|
|
bootm_headers_t *images, boot_os_fn *boot_fn);
|
|
diff --git a/tools/Makefile b/tools/Makefile
|
|
index 081383d7a7..4d23c3941e 100644
|
|
--- a/tools/Makefile
|
|
+++ b/tools/Makefile
|
|
@@ -58,6 +58,7 @@ hostprogs-$(CONFIG_FIT_SIGNATURE) += fit_info fit_check_sign
|
|
|
|
hostprogs-$(CONFIG_CMD_BOOTEFI_SELFTEST) += file2include
|
|
|
|
+FIT_OBJS-$(CONFIG_FIT) := fit_common.o fit_image.o image-host.o common/image-fit.o
|
|
FIT_SIG_OBJS-$(CONFIG_FIT_SIGNATURE) := common/image-sig.o
|
|
|
|
# The following files are synced with upstream DTC.
|
|
@@ -80,16 +81,13 @@ ROCKCHIP_OBS = lib/rc4.o rkcommon.o rkimage.o rksd.o rkspi.o
|
|
# common objs for dumpimage and mkimage
|
|
dumpimage-mkimage-objs := aisimage.o \
|
|
atmelimage.o \
|
|
+ $(FIT_OBJS-y) \
|
|
$(FIT_SIG_OBJS-y) \
|
|
common/bootm.o \
|
|
lib/crc32.o \
|
|
default_image.o \
|
|
lib/fdtdec_common.o \
|
|
lib/fdtdec.o \
|
|
- fit_common.o \
|
|
- fit_image.o \
|
|
- common/image-fit.o \
|
|
- image-host.o \
|
|
common/image.o \
|
|
imagetool.o \
|
|
imximage.o \
|
|
--
|
|
2.20.1
|
|
|