package/uboot-tools: bump to version 2019.01
Adapt patch 0002 and 0003 for version 2019.01. Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
0cd5b4fa0c
commit
6ff3da375b
@ -1,4 +1,4 @@
|
||||
From b8110293d70c4f43035dfd6a0904d342be6a08e0 Mon Sep 17 00:00:00 2001
|
||||
From 460646b3c4c1718860915c38586ee8d2fbda38e4 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?J=C3=B6rg=20Krause?= <joerg.krause@embedded.rocks>
|
||||
Date: Sun, 1 Feb 2015 21:53:47 +0100
|
||||
Subject: [PATCH] tools only in no dot config targets
|
||||
@ -25,18 +25,18 @@ Signed-off-by: Fabio Estevam <fabio.estevam@nxp.com>
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 1cf15ce..75e85eb 100644
|
||||
index 6aa08964ff..fcec83d183 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -425,7 +425,7 @@ timestamp_h := include/generated/timestamp_autogenerated.h
|
||||
@@ -443,7 +443,7 @@ defaultenv_h := include/generated/defaultenv_autogenerated.h
|
||||
|
||||
no-dot-config-targets := clean clobber mrproper distclean \
|
||||
help %docs check% coccicheck \
|
||||
- ubootversion backup tests
|
||||
+ ubootversion backup tests tools-only
|
||||
- ubootversion backup tests check qcheck
|
||||
+ ubootversion backup tests tools-only check qcheck
|
||||
|
||||
config-targets := 0
|
||||
mixed-targets := 0
|
||||
--
|
||||
2.7.4
|
||||
2.20.1
|
||||
|
||||
|
@ -1,7 +1,10 @@
|
||||
From d9d7d7cf8b27516d45c66daa1bf0a18c878c4e33 Mon Sep 17 00:00:00 2001
|
||||
From 794aeeb82ab7c0304e343499ee5d82c1f1c5c39a Mon Sep 17 00:00:00 2001
|
||||
From: Carlos Santos <casantos@datacom.ind.br>
|
||||
Date: Sun, 8 May 2016 11:11:39 -0300
|
||||
Subject: [PATCH] Make FIT support really optional
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Due to some mistakes in the source code, it was not possible to really
|
||||
turn FIT support off. This commit fixes the problem by means of the
|
||||
@ -22,6 +25,8 @@ Signed-off-by: Fabio Estevam <festevam@gmail.com>
|
||||
[Ricardo: fix conditional compilation and linking of the files mentioned above
|
||||
for 2016.07]
|
||||
Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
|
||||
[Jörg: adapt for 2019.01]
|
||||
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
|
||||
---
|
||||
common/bootm.c | 2 ++
|
||||
include/bootm.h | 2 ++
|
||||
@ -29,10 +34,10 @@ Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
|
||||
3 files changed, 6 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/common/bootm.c b/common/bootm.c
|
||||
index 2431019..7e1adc8 100644
|
||||
index 8bf84ebcb7..ecc29fb7b4 100644
|
||||
--- a/common/bootm.c
|
||||
+++ b/common/bootm.c
|
||||
@@ -901,6 +901,7 @@ void memmove_wd(void *to, void *from, size_t len, ulong chunksz)
|
||||
@@ -922,6 +922,7 @@ void memmove_wd(void *to, void *from, size_t len, ulong chunksz)
|
||||
memmove(to, from, len);
|
||||
}
|
||||
|
||||
@ -40,7 +45,7 @@ index 2431019..7e1adc8 100644
|
||||
static int bootm_host_load_image(const void *fit, int req_image_type)
|
||||
{
|
||||
const char *fit_uname_config = NULL;
|
||||
@@ -965,5 +966,6 @@ int bootm_host_load_images(const void *fit, int cfg_noffset)
|
||||
@@ -986,5 +987,6 @@ int bootm_host_load_images(const void *fit, int cfg_noffset)
|
||||
/* Return the first error we found */
|
||||
return err;
|
||||
}
|
||||
@ -48,10 +53,10 @@ index 2431019..7e1adc8 100644
|
||||
|
||||
#endif /* ndef USE_HOSTCC */
|
||||
diff --git a/include/bootm.h b/include/bootm.h
|
||||
index 4981377..94d62a1 100644
|
||||
index dbd6f49c2d..f5fe9cb2d3 100644
|
||||
--- a/include/bootm.h
|
||||
+++ b/include/bootm.h
|
||||
@@ -41,7 +41,9 @@ void lynxkdi_boot(image_header_t *hdr);
|
||||
@@ -42,7 +42,9 @@ void lynxkdi_boot(image_header_t *hdr);
|
||||
|
||||
boot_os_fn *bootm_os_get_boot_func(int os);
|
||||
|
||||
@ -62,18 +67,18 @@ index 4981377..94d62a1 100644
|
||||
int boot_selected_os(int argc, char * const argv[], int state,
|
||||
bootm_headers_t *images, boot_os_fn *boot_fn);
|
||||
diff --git a/tools/Makefile b/tools/Makefile
|
||||
index f72294a..ccf5120 100644
|
||||
index 081383d7a7..4d23c3941e 100644
|
||||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -54,6 +54,7 @@ mkenvimage-objs := mkenvimage.o os_support.o lib/crc32.o
|
||||
hostprogs-y += dumpimage mkimage
|
||||
hostprogs-$(CONFIG_FIT_SIGNATURE) += fit_info fit_check_sign
|
||||
@@ -58,6 +58,7 @@ hostprogs-$(CONFIG_FIT_SIGNATURE) += fit_info fit_check_sign
|
||||
|
||||
hostprogs-$(CONFIG_CMD_BOOTEFI_SELFTEST) += file2include
|
||||
|
||||
+FIT_OBJS-$(CONFIG_FIT) := fit_common.o fit_image.o image-host.o common/image-fit.o
|
||||
FIT_SIG_OBJS-$(CONFIG_FIT_SIGNATURE) := common/image-sig.o
|
||||
# Flattened device tree objects
|
||||
LIBFDT_OBJS := $(addprefix lib/libfdt/, \
|
||||
@@ -68,16 +69,13 @@ ROCKCHIP_OBS = lib/rc4.o rkcommon.o rkimage.o rksd.o rkspi.o
|
||||
|
||||
# The following files are synced with upstream DTC.
|
||||
@@ -80,16 +81,13 @@ ROCKCHIP_OBS = lib/rc4.o rkcommon.o rkimage.o rksd.o rkspi.o
|
||||
# common objs for dumpimage and mkimage
|
||||
dumpimage-mkimage-objs := aisimage.o \
|
||||
atmelimage.o \
|
||||
@ -92,5 +97,5 @@ index f72294a..ccf5120 100644
|
||||
imagetool.o \
|
||||
imximage.o \
|
||||
--
|
||||
2.9.1
|
||||
2.20.1
|
||||
|
||||
|
@ -1,2 +1,2 @@
|
||||
# Locally computed:
|
||||
sha256 9f10df88bc91b35642e461217f73256bbaeeca9ae2db8db56197ba5e89e1f6d4 u-boot-2018.07.tar.bz2
|
||||
sha256 50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22 u-boot-2019.01.tar.bz2
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
UBOOT_TOOLS_VERSION = 2018.07
|
||||
UBOOT_TOOLS_VERSION = 2019.01
|
||||
UBOOT_TOOLS_SOURCE = u-boot-$(UBOOT_TOOLS_VERSION).tar.bz2
|
||||
UBOOT_TOOLS_SITE = ftp://ftp.denx.de/pub/u-boot
|
||||
UBOOT_TOOLS_LICENSE = GPL-2.0+
|
||||
|
Loading…
Reference in New Issue
Block a user