When using the buildroot compiler, it builds the u-boot.itb immediately after building the fit-dtb.blob. This causes a build failure when using the CONFIG_MULTI_DTB_FIT build configuration. This patch adds the necessary dependency to guarantee that the fit-dtb.blob has finished building before trying to build the u-boot.itb. Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/3310463281 This patch has been submitted to u-boot mainline: https://lore.kernel.org/all/20221221075446.47141-1-neal.frager@amd.com/ Signed-off-by: Neal Frager <neal.frager@amd.com> Reviewed-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
33 lines
1.0 KiB
Diff
33 lines
1.0 KiB
Diff
From 8b181bf582c17cf709a62cf499f9709c94f49d33 Mon Sep 17 00:00:00 2001
|
|
From: Neal Frager <neal.frager@amd.com>
|
|
Date: Wed, 21 Dec 2022 07:51:42 +0000
|
|
Subject: [PATCH v1 1/1] makefile: add multi_dtb_fit dep
|
|
|
|
With certain gcc compilers, the u-boot.itb is built immediately after dtb
|
|
generation. If CONFIG_MULTI_DTB_FIT is used, it is possible that the
|
|
fit-dtb.blob is not finished in time.
|
|
|
|
This patch adds a necessary dependency to guarantee that the fit-dtb.blob
|
|
is built before attempting to build the u-boot.itb.
|
|
|
|
Signed-off-by: Neal Frager <neal.frager@amd.com>
|
|
---
|
|
Makefile | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index b96e2ffa15..682a5d94fd 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1425,6 +1425,7 @@ MKIMAGEFLAGS_u-boot.itb += -B 0x8
|
|
ifdef U_BOOT_ITS
|
|
u-boot.itb: u-boot-nodtb.bin \
|
|
$(if $(CONFIG_OF_SEPARATE)$(CONFIG_OF_EMBED)$(CONFIG_SANDBOX),dts/dt.dtb) \
|
|
+ $(if $(CONFIG_MULTI_DTB_FIT),$(FINAL_DTB_CONTAINER)) \
|
|
$(U_BOOT_ITS) FORCE
|
|
$(call if_changed,mkfitimage)
|
|
$(BOARD_SIZE_CHECK)
|
|
--
|
|
2.17.1
|
|
|