configs/zynqmp_kria_kv260_defconfig: use CONFIG_MULTI_DTB_FIT
When using the buildroot compiler, it builds the u-boot.itb immediately after building the fit-dtb.blob. This causes a build failure when using the CONFIG_MULTI_DTB_FIT build configuration. This patch adds the necessary dependency to guarantee that the fit-dtb.blob has finished building before trying to build the u-boot.itb. Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/3310463281 This patch has been submitted to u-boot mainline: https://lore.kernel.org/all/20221221075446.47141-1-neal.frager@amd.com/ Signed-off-by: Neal Frager <neal.frager@amd.com> Reviewed-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
7a029f6e88
commit
250d7df53a
@ -8,5 +8,5 @@
|
||||
|
||||
UBOOT_DIR=$4
|
||||
|
||||
fdtoverlay -o ${UBOOT_DIR}/arch/arm/dts/zynqmp-smk-k26-revA.dtb -i ${UBOOT_DIR}/arch/arm/dts/zynqmp-smk-k26-revA.dtb ${UBOOT_DIR}/arch/arm/dts/zynqmp-sck-kv-g-revB.dtbo
|
||||
fdtoverlay -o ${UBOOT_DIR}/fit-dtb.blob -i ${UBOOT_DIR}/arch/arm/dts/zynqmp-smk-k26-revA.dtb ${UBOOT_DIR}/arch/arm/dts/zynqmp-sck-kv-g-revB.dtbo
|
||||
${UBOOT_DIR}/tools/mkimage -E -f ${UBOOT_DIR}/u-boot.its -B 0x8 ${BINARIES_DIR}/u-boot.itb
|
||||
|
@ -0,0 +1,32 @@
|
||||
From 8b181bf582c17cf709a62cf499f9709c94f49d33 Mon Sep 17 00:00:00 2001
|
||||
From: Neal Frager <neal.frager@amd.com>
|
||||
Date: Wed, 21 Dec 2022 07:51:42 +0000
|
||||
Subject: [PATCH v1 1/1] makefile: add multi_dtb_fit dep
|
||||
|
||||
With certain gcc compilers, the u-boot.itb is built immediately after dtb
|
||||
generation. If CONFIG_MULTI_DTB_FIT is used, it is possible that the
|
||||
fit-dtb.blob is not finished in time.
|
||||
|
||||
This patch adds a necessary dependency to guarantee that the fit-dtb.blob
|
||||
is built before attempting to build the u-boot.itb.
|
||||
|
||||
Signed-off-by: Neal Frager <neal.frager@amd.com>
|
||||
---
|
||||
Makefile | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index b96e2ffa15..682a5d94fd 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1425,6 +1425,7 @@ MKIMAGEFLAGS_u-boot.itb += -B 0x8
|
||||
ifdef U_BOOT_ITS
|
||||
u-boot.itb: u-boot-nodtb.bin \
|
||||
$(if $(CONFIG_OF_SEPARATE)$(CONFIG_OF_EMBED)$(CONFIG_SANDBOX),dts/dt.dtb) \
|
||||
+ $(if $(CONFIG_MULTI_DTB_FIT),$(FINAL_DTB_CONTAINER)) \
|
||||
$(U_BOOT_ITS) FORCE
|
||||
$(call if_changed,mkfitimage)
|
||||
$(BOARD_SIZE_CHECK)
|
||||
--
|
||||
2.17.1
|
||||
|
@ -1,4 +1,5 @@
|
||||
CONFIG_SYS_SPI_U_BOOT_OFFS=0xF80000
|
||||
CONFIG_MULTI_DTB_FIT=y
|
||||
CONFIG_DTB_RESELECT=y
|
||||
CONFIG_DMA=y
|
||||
CONFIG_XILINX_DPDMA=y
|
||||
|
@ -38,3 +38,4 @@ BR2_TARGET_UBOOT_NEEDS_ATF_BL31=y
|
||||
BR2_PACKAGE_HOST_DOSFSTOOLS=y
|
||||
BR2_PACKAGE_HOST_GENIMAGE=y
|
||||
BR2_PACKAGE_HOST_MTOOLS=y
|
||||
BR2_GLOBAL_PATCH_DIR="board/zynqmp/kria/patches"
|
||||
|
Loading…
Reference in New Issue
Block a user