kumquat-buildroot/package/mesa3d/0004-Fix-uClibc-build.patch
Bernd Kuhls e4a1183d8f package/{mesa3d, mesa3d-headers}: bump version to 22.3.0
Removed xmvc support due to upstream removal:
https://cgit.freedesktop.org/mesa/mesa/commit/meson.build?h=22.3&id=8cc766d8f7eac26b7c029a2fac1bdfdba4776c29

Removed comment concerning gallium-xlib due to upstream removal:
https://cgit.freedesktop.org/mesa/mesa/commit/meson.build?h=22.3&id=5bed3d4ad659c30cb0ef4b40172f1aab877ccc98

Rebased patch 0004 due to upstream commit:
https://cgit.freedesktop.org/mesa/mesa/commit/src/util/macros.h?h=22.3&id=c0b891ecca2b92c9ef2945440c77f45345df3290

Please note that patch 0004 can be removed when buildroot toolchains are
updated to uClibc 1.0.42:
https://cgit.uclibc-ng.org/cgi/cgit/uclibc-ng.git/commit/?h=v1.0.42&id=03fbd941e943976bb92cb392882c2ff7ec218704

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2022-12-11 18:15:09 +01:00

71 lines
2.0 KiB
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

From 09ce52fe375a6fc1ccf51b6b691aaa2c3f53fbd5 Mon Sep 17 00:00:00 2001
From: Bernd Kuhls <bernd.kuhls@t-online.de>
Date: Fri, 3 Jun 2022 16:26:03 +0200
Subject: [PATCH] Fix uClibc build
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Fixes build errors with uClibc and gcc-9.3.0:
../src/gallium/drivers/lima/lima_texture.c:47:15: error: expected
declaration specifiers or ... before __builtin_offsetof
47 | static_assert(offsetof(lima_tex_desc, va) == 24,
"lima_tex_desc->va offset isn't 24");
../src/egl/main/egldisplay.c: In function _eglGetNativePlatformFromEnv:
../src/egl/main/egldisplay.c:101:4: error: implicit declaration of
function static_assert [-Werror=implicit-function-declaration] 101 |
static_assert(ARRAY_SIZE(egl_platforms) == _EGL_NUM_PLATFORMS,
../src/util/macros.h:74:4: error: implicit declaration of function
static_assert [-Werror=implicit-function-declaration]
74 | static_assert(cond, #cond); \
| ^~~~~~~~~~~~~
Patch sent upstream:
https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/13898
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
src/util/compiler.h | 10 ++++++++++
src/util/macros.h | 1 +
2 files changed, 11 insertions(+)
diff --git a/src/util/compiler.h b/src/util/compiler.h
index d184ad455af..b5c56807acc 100644
--- a/src/util/compiler.h
+++ b/src/util/compiler.h
@@ -36,6 +36,16 @@
#include <assert.h>
+/*
+ * C11 static_assert() macro
+ * assert.h only defines that name for C11 and above
+ */
+#if !defined(__cplusplus)
+#ifndef static_assert
+#define static_assert _Static_assert
+#endif
+#endif
+
#include "util/macros.h"
diff --git a/src/util/macros.h b/src/util/macros.h
index 22b18303826..8f73ee72693 100644
--- a/src/util/macros.h
+++ b/src/util/macros.h
@@ -27,6 +27,7 @@
#include <stddef.h>
#include <stdint.h>
#include <stdio.h>
+#include "util/compiler.h"
/* Compute the size of an array */
#ifndef ARRAY_SIZE
--
2.34.1