package/{mesa3d, mesa3d-headers}: bump version to 22.3.0
Removed xmvc support due to upstream removal: https://cgit.freedesktop.org/mesa/mesa/commit/meson.build?h=22.3&id=8cc766d8f7eac26b7c029a2fac1bdfdba4776c29 Removed comment concerning gallium-xlib due to upstream removal: https://cgit.freedesktop.org/mesa/mesa/commit/meson.build?h=22.3&id=5bed3d4ad659c30cb0ef4b40172f1aab877ccc98 Rebased patch 0004 due to upstream commit: https://cgit.freedesktop.org/mesa/mesa/commit/src/util/macros.h?h=22.3&id=c0b891ecca2b92c9ef2945440c77f45345df3290 Please note that patch 0004 can be removed when buildroot toolchains are updated to uClibc 1.0.42: https://cgit.uclibc-ng.org/cgi/cgit/uclibc-ng.git/commit/?h=v1.0.42&id=03fbd941e943976bb92cb392882c2ff7ec218704 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
7402436beb
commit
e4a1183d8f
Config.in.legacy
package
@ -146,6 +146,12 @@ endif
|
||||
|
||||
comment "Legacy options removed in 2023.02"
|
||||
|
||||
config BR2_PACKAGE_MESA3D_XVMC
|
||||
bool "mesa Gallium XvMC state tracker removed"
|
||||
select BR2_LEGACY
|
||||
help
|
||||
The Gallium XvMC state tracker was removed upstream.
|
||||
|
||||
config BR2_KERNEL_HEADERS_5_19
|
||||
bool "kernel headers version 5.19.x are no longer supported"
|
||||
select BR2_LEGACY
|
||||
|
@ -12,7 +12,7 @@ endif
|
||||
|
||||
# Not possible to directly refer to mesa3d variables, because of
|
||||
# first/second expansion trickery...
|
||||
MESA3D_HEADERS_VERSION = 22.2.2
|
||||
MESA3D_HEADERS_VERSION = 22.3.0
|
||||
MESA3D_HEADERS_SOURCE = mesa-$(MESA3D_HEADERS_VERSION).tar.xz
|
||||
MESA3D_HEADERS_SITE = https://archive.mesa3d.org
|
||||
MESA3D_HEADERS_DL_SUBDIR = mesa3d
|
||||
|
@ -58,9 +58,9 @@ index 22b18303826..8f73ee72693 100644
|
||||
--- a/src/util/macros.h
|
||||
+++ b/src/util/macros.h
|
||||
@@ -27,6 +27,7 @@
|
||||
#include <stdio.h>
|
||||
#include <assert.h>
|
||||
#include <stddef.h>
|
||||
#include <stdint.h>
|
||||
#include <stdio.h>
|
||||
+#include "util/compiler.h"
|
||||
|
||||
/* Compute the size of an array */
|
||||
|
@ -299,24 +299,6 @@ comment "Gallium VDPAU state tracker needs X.org and gallium drivers r300, r600,
|
||||
|| BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600 \
|
||||
|| BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_RADEONSI)
|
||||
|
||||
config BR2_PACKAGE_MESA3D_XVMC
|
||||
bool "Gallium XvMC state tracker"
|
||||
depends on BR2_i386 || BR2_x86_64
|
||||
depends on BR2_PACKAGE_XORG7
|
||||
depends on BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU \
|
||||
|| BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600
|
||||
select BR2_PACKAGE_MESA3D_NEEDS_X11
|
||||
select BR2_PACKAGE_XLIB_LIBXV
|
||||
select BR2_PACKAGE_XLIB_LIBXVMC
|
||||
help
|
||||
XvMC state tracker (needs r600 or nouveau gallium drivers).
|
||||
|
||||
comment "Gallium XvMC state tracker needs X.org and gallium drivers r600 or nouveau"
|
||||
depends on BR2_i386 || BR2_x86_64
|
||||
depends on !BR2_PACKAGE_XORG7 || \
|
||||
!(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU \
|
||||
|| BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600)
|
||||
|
||||
comment "Vulkan drivers"
|
||||
|
||||
config BR2_PACKAGE_MESA3D_VULKAN_DRIVER_INTEL
|
||||
|
@ -1,5 +1,5 @@
|
||||
# From https://lists.freedesktop.org/archives/mesa-announce/2022-October/000689.html
|
||||
sha256 2de11fb74fc5cc671b818e49fe203cea0cd1d8b69756e97cdb06a2f4e78948f9 mesa-22.2.2.tar.xz
|
||||
sha512 a1eb67e1ae4880c79b1fdc570f4389baba0b8ba796da7e695c9af19a7d92b6c06b95570e6c796548b61355989025fb7efbf9acac74cbd695f7e297dc913b933c mesa-22.2.2.tar.xz
|
||||
# From https://lists.freedesktop.org/archives/mesa-announce/2022-November/000695.html
|
||||
sha256 644bf936584548c2b88762111ad58b4aa3e4688874200e5a4eb74e53ce301746 mesa-22.3.0.tar.xz
|
||||
sha512 bf4d344459f97d266a5943b33aecf062b0825e13c1617afdab71c4ba6a87a201440761c9a32a6e0060910a0917122e3f4d29f666d6b94a38a71c94b9ff3ab9da mesa-22.3.0.tar.xz
|
||||
# License
|
||||
sha256 a00275a53178e2645fb65be99a785c110513446a5071ff2c698ed260ad917d75 docs/license.rst
|
||||
|
@ -5,7 +5,7 @@
|
||||
################################################################################
|
||||
|
||||
# When updating the version, please also update mesa3d-headers
|
||||
MESA3D_VERSION = 22.2.2
|
||||
MESA3D_VERSION = 22.3.0
|
||||
MESA3D_SOURCE = mesa-$(MESA3D_VERSION).tar.xz
|
||||
MESA3D_SITE = https://archive.mesa3d.org
|
||||
MESA3D_LICENSE = MIT, SGI, Khronos
|
||||
@ -77,7 +77,6 @@ ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_GLX),y)
|
||||
# glx:
|
||||
# dri : dri based GLX requires at least one DRI driver || dri based GLX requires shared-glapi
|
||||
# xlib : xlib conflicts with any dri driver
|
||||
# gallium-xlib : Gallium-xlib based GLX requires at least one gallium driver || Gallium-xlib based GLX requires softpipe or llvmpipe || gallium-xlib conflicts with any dri driver.
|
||||
# Always enable glx-direct; without it, many GLX applications don't work.
|
||||
MESA3D_CONF_OPTS += \
|
||||
-Dglx=dri \
|
||||
@ -212,13 +211,6 @@ else
|
||||
MESA3D_CONF_OPTS += -Dgles1=disabled -Dgles2=disabled
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_MESA3D_XVMC),y)
|
||||
MESA3D_DEPENDENCIES += xlib_libXv xlib_libXvMC
|
||||
MESA3D_CONF_OPTS += -Dgallium-xvmc=enabled
|
||||
else
|
||||
MESA3D_CONF_OPTS += -Dgallium-xvmc=disabled
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_VALGRIND),y)
|
||||
MESA3D_CONF_OPTS += -Dvalgrind=enabled
|
||||
MESA3D_DEPENDENCIES += valgrind
|
||||
|
Loading…
Reference in New Issue
Block a user