9cf8f4e134
Drop override system locale patch which is now upstream. Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
72 lines
2.0 KiB
Diff
72 lines
2.0 KiB
Diff
From dd2722dec08eb9c72c36313e93661eeca3ad64d8 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 22 Feb 2017 17:20:45 -0800
|
|
Subject: [PATCH] Add option to disable the sqlite3 module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
[ Andrey Smirnov: ported to Python 3.6 ]
|
|
Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
|
|
[ Adam Duskett: ported to Python 3.10.0 ]
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
---
|
|
Makefile.pre.in | 7 +++++--
|
|
configure.ac | 9 +++++++++
|
|
2 files changed, 14 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index 5847029..5628860 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1446,7 +1446,6 @@ LIBSUBDIRS= asyncio \
|
|
logging \
|
|
multiprocessing multiprocessing/dummy \
|
|
site-packages \
|
|
- sqlite3 \
|
|
tkinter \
|
|
turtledemo \
|
|
unittest \
|
|
@@ -1459,7 +1458,6 @@ LIBSUBDIRS= asyncio \
|
|
TESTSUBDIRS= ctypes/test \
|
|
distutils/tests \
|
|
idlelib/idle_test \
|
|
- sqlite3/test \
|
|
test test/audiodata \
|
|
test/capath test/cjkencodings \
|
|
test/data test/decimaltestdata \
|
|
@@ -1540,6 +1538,11 @@ TESTSUBDIRS += lib2to3/tests \
|
|
lib2to3/tests/data/fixers/myfixes
|
|
endif
|
|
|
|
+ifeq (@SQLITE3@,yes)
|
|
+LIBSUBDIRS += sqlite3
|
|
+TESTSUBDIRS += sqlite3/test
|
|
+endif
|
|
+
|
|
TEST_MODULES=@TEST_MODULES@
|
|
libinstall: build_all $(srcdir)/Modules/xxmodule.c
|
|
@for i in $(SCRIPTDIR) $(LIBDEST); \
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 34c2ba9..dfee472 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3373,6 +3373,15 @@ if test "$posix_threads" = "yes"; then
|
|
AC_CHECK_FUNCS(pthread_getcpuclockid)
|
|
fi
|
|
|
|
+AC_SUBST(SQLITE3)
|
|
+AC_ARG_ENABLE(sqlite3,
|
|
+ AS_HELP_STRING([--disable-sqlite3], [disable sqlite3]),
|
|
+ [ SQLITE3="${enableval}" ], [ SQLITE3=yes ])
|
|
+
|
|
+if test "$SQLITE3" = "no" ; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
|
|
+fi
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|
|
--
|
|
2.30.2
|
|
|