package/python3: bump to version 3.10.4
Drop override system locale patch which is now upstream. Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
034928ec5c
commit
9cf8f4e134
@ -1,39 +0,0 @@
|
||||
From e4ae670e3489544a49dabd1618c32fe73504a7ba Mon Sep 17 00:00:00 2001
|
||||
From: Samuel Cabrero <samuelcabrero@gmail.com>
|
||||
Date: Wed, 23 Dec 2015 11:45:48 +0100
|
||||
Subject: [PATCH] Override system locale and set to default when adding gcc
|
||||
paths
|
||||
|
||||
Forces the use of the default locale in the function
|
||||
add_gcc_paths, which is called when cross compiling to add the
|
||||
include and library paths. This is necessary because otherwise
|
||||
the gcc output is localized and the output parsing fails, which
|
||||
results in no paths added and detect_modules not able to find
|
||||
any system library (eg. libz, libssl, etc.)
|
||||
|
||||
[Thomas: patch taken from https://bugs.python.org/issue23767.]
|
||||
|
||||
Signed-off-by: Samuel Cabrero <samuelcabrero@gmail.com>
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
[james.hilliard1@gmail.com: adapt to python 3.9]
|
||||
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
|
||||
---
|
||||
setup.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index d3f0e663f2..926c16f58f 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -761,7 +761,7 @@ class PyBuildExt(build_ext):
|
||||
tmpfile = os.path.join(self.build_temp, 'ccpaths')
|
||||
if not os.path.exists(self.build_temp):
|
||||
os.makedirs(self.build_temp)
|
||||
- ret = run_command('%s -E -v - </dev/null 2>%s 1>/dev/null' % (CC, tmpfile))
|
||||
+ ret = run_command('LC_ALL=C %s -E -v - </dev/null 2>%s 1>/dev/null' % (CC, tmpfile))
|
||||
is_gcc = False
|
||||
is_clang = False
|
||||
in_incdirs = False
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,5 +1,5 @@
|
||||
# From https://www.python.org/downloads/release/python-3102/
|
||||
md5 14e8c22458ed7779a1957b26cde01db9 Python-3.10.2.tar.xz
|
||||
# From https://www.python.org/downloads/release/python-3104/
|
||||
md5 21f2e113e087083a1e8cf10553d93599 Python-3.10.4.tar.xz
|
||||
# Locally computed
|
||||
sha256 17de3ac7da9f2519aa9d64378c603a73a0e9ad58dffa8812e45160c086de64c7 Python-3.10.2.tar.xz
|
||||
sha256 80bf925f571da436b35210886cf79f6eb5fa5d6c571316b73568343451f77a19 Python-3.10.4.tar.xz
|
||||
sha256 f03e17cd594c2085f66a454e695c7ebe5b4d3c0eff534f4f194abc2fd164621b LICENSE
|
||||
|
@ -5,7 +5,7 @@
|
||||
################################################################################
|
||||
|
||||
PYTHON3_VERSION_MAJOR = 3.10
|
||||
PYTHON3_VERSION = $(PYTHON3_VERSION_MAJOR).2
|
||||
PYTHON3_VERSION = $(PYTHON3_VERSION_MAJOR).4
|
||||
PYTHON3_SOURCE = Python-$(PYTHON3_VERSION).tar.xz
|
||||
PYTHON3_SITE = https://python.org/ftp/python/$(PYTHON3_VERSION)
|
||||
PYTHON3_LICENSE = Python-2.0, others
|
||||
|
Loading…
Reference in New Issue
Block a user