1c2f90f44d
This commit dropped a patch included upstream. The other patch was rebased. For change log since v0.3.18, see: - https://github.com/xianyi/OpenBLAS/releases/tag/v0.3.19 - https://github.com/xianyi/OpenBLAS/releases/tag/v0.3.20 Signed-off-by: Julien Olivain <ju.o@free.fr> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
40 lines
1.1 KiB
Diff
40 lines
1.1 KiB
Diff
From d8ec4e4c6ef69165179f376e365034de10e6fee3 Mon Sep 17 00:00:00 2001
|
|
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
|
|
Date: Fri, 5 Mar 2021 14:09:23 +0100
|
|
Subject: [PATCH] Makefile.system: don't specify optimization level
|
|
[buildroot-specific]
|
|
|
|
Buildroot will pass an optimization level, but it is ignored because the
|
|
openblas makefiles _append_ to the flags passed on the command-line.
|
|
|
|
The CFLAGS/FFLAGS would e.g. contain '-Os -O2' in which -O2 survives.
|
|
|
|
Remove the optimization level specified in openblas itself.
|
|
|
|
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
|
|
---
|
|
Makefile.system | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile.system b/Makefile.system
|
|
index 438a8148..9de1bbd5 100644
|
|
--- a/Makefile.system
|
|
+++ b/Makefile.system
|
|
@@ -1519,11 +1519,11 @@ FCOMMON_OPT += -g
|
|
endif
|
|
|
|
ifndef COMMON_OPT
|
|
-COMMON_OPT = -O2
|
|
+COMMON_OPT =
|
|
endif
|
|
|
|
ifndef FCOMMON_OPT
|
|
-FCOMMON_OPT = -O2 -frecursive
|
|
+FCOMMON_OPT = -frecursive
|
|
endif
|
|
|
|
override CFLAGS += $(COMMON_OPT) $(CCOMMON_OPT) -I$(TOPDIR)
|
|
--
|
|
2.35.1
|
|
|