package/openblas: bump to version v0.3.20

This commit dropped a patch included upstream. The other patch was
rebased.

For change log since v0.3.18, see:
- https://github.com/xianyi/OpenBLAS/releases/tag/v0.3.19
- https://github.com/xianyi/OpenBLAS/releases/tag/v0.3.20

Signed-off-by: Julien Olivain <ju.o@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Julien Olivain 2022-03-05 18:50:41 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 4e1e941b67
commit 1c2f90f44d
4 changed files with 6 additions and 38 deletions

View File

@ -1,31 +0,0 @@
From ced08de1ad74811bc23d74121751537bfd8e9556 Mon Sep 17 00:00:00 2001
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Date: Fri, 5 Mar 2021 11:15:52 +0100
Subject: [PATCH] Makefile: also consider -O, -Og and -Os when stripping flags
gcc also supports -O, -Og and -Os as optimization flags.
They may be given on the make command-line by users.
For the calculation of LAPACK_NOOPT, all such flags should be considered.
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index a22e16ba..fc5fe3f5 100644
--- a/Makefile
+++ b/Makefile
@@ -32,7 +32,7 @@ export NOFORTRAN
export NO_LAPACK
endif
-LAPACK_NOOPT := $(filter-out -O0 -O1 -O2 -O3 -Ofast,$(LAPACK_FFLAGS))
+LAPACK_NOOPT := $(filter-out -O0 -O1 -O2 -O3 -Ofast -O -Og -Os,$(LAPACK_FFLAGS))
SUBDIRS_ALL = $(SUBDIRS) test ctest utest exports benchmark ../laswp ../bench cpp_thread_test
--
2.26.2

View File

@ -1,4 +1,4 @@
From 6d1c1350977d74fb2239f765bd92a5763cd3bb73 Mon Sep 17 00:00:00 2001
From d8ec4e4c6ef69165179f376e365034de10e6fee3 Mon Sep 17 00:00:00 2001
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Date: Fri, 5 Mar 2021 14:09:23 +0100
Subject: [PATCH] Makefile.system: don't specify optimization level
@ -12,16 +12,15 @@ The CFLAGS/FFLAGS would e.g. contain '-Os -O2' in which -O2 survives.
Remove the optimization level specified in openblas itself.
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
---
Makefile.system | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile.system b/Makefile.system
index 1e30d05a..04b0be16 100644
index 438a8148..9de1bbd5 100644
--- a/Makefile.system
+++ b/Makefile.system
@@ -1216,11 +1216,11 @@ FCOMMON_OPT += -g
@@ -1519,11 +1519,11 @@ FCOMMON_OPT += -g
endif
ifndef COMMON_OPT
@ -36,5 +35,5 @@ index 1e30d05a..04b0be16 100644
override CFLAGS += $(COMMON_OPT) $(CCOMMON_OPT) -I$(TOPDIR)
--
2.26.2
2.35.1

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 1632c1e8cca62d8bed064b37747e331a1796fc46f688626337362bf0d16aeadb openblas-0.3.18.tar.gz
sha256 8495c9affc536253648e942908e88e097f2ec7753ede55aca52e5dead3029e3c openblas-0.3.20.tar.gz
sha256 190b5a9c8d9723fe958ad33916bd7346d96fab3c5ea90832bb02d854f620fcff LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
OPENBLAS_VERSION = 0.3.18
OPENBLAS_VERSION = 0.3.20
OPENBLAS_SITE = https://github.com/xianyi/OpenBLAS/releases/download/v$(OPENBLAS_VERSION)
OPENBLAS_LICENSE = BSD-3-Clause
OPENBLAS_LICENSE_FILES = LICENSE