252ad90833
Backport upstream patch which adds explicit_bzero() autoconf detection, which fixes br-arm-cortex-a9-glibc and br-arm-full-static build: In file included from ell/random.c:34: ell/missing.h:59:20: error: static declaration of ‘explicit_bzero’ follows non-static declaration static inline void explicit_bzero(void *s, size_t n) ^~~~~~~~~~~~~~ In file included from ./ell/util.h:26, from ell/private.h:26, from ell/random.c:33: /home/pvorel/br-test-pkg/br-arm-cortex-a9-glibc/host/arm-buildroot-linux-gnueabihf/sysroot/usr/include/string.h:435:13: note: previous declaration of ‘explicit_bzero’ was here extern void explicit_bzero (void *__s, size_t __n) __THROW __nonnull ((1)); ^~~~~~~~~~~~~~ Signed-off-by: Petr Vorel <petr.vorel@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
29 lines
697 B
Diff
29 lines
697 B
Diff
From dff595671bf5a46f7c9231966a6cd7d2a0183076 Mon Sep 17 00:00:00 2001
|
|
From: Marcel Holtmann <marcel@holtmann.org>
|
|
Date: Wed, 15 May 2019 09:39:44 +0200
|
|
Subject: [PATCH] build: Add check for explicit_bzero support
|
|
|
|
Upstream: dff595671bf5a46f7c9231966a6cd7d2a0183076
|
|
|
|
Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
|
|
---
|
|
configure.ac | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index bacb7ac5..cad35c5d 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -54,6 +54,8 @@ AC_ARG_ENABLE(pie, AC_HELP_STRING([--enable-pie],
|
|
fi
|
|
])
|
|
|
|
+AC_CHECK_FUNCS(explicit_bzero)
|
|
+
|
|
AC_CHECK_FUNC(signalfd, dummy=yes,
|
|
AC_MSG_ERROR(signalfd support is required))
|
|
|
|
--
|
|
2.21.0
|
|
|