package/ofono: bump to version 1.29

Backport upstream patch which adds explicit_bzero() autoconf detection,
which fixes br-arm-cortex-a9-glibc and br-arm-full-static build:

In file included from ell/random.c:34:
ell/missing.h:59:20: error: static declaration of ‘explicit_bzero’ follows non-static declaration
 static inline void explicit_bzero(void *s, size_t n)
                    ^~~~~~~~~~~~~~
In file included from ./ell/util.h:26,
                 from ell/private.h:26,
                 from ell/random.c:33:
/home/pvorel/br-test-pkg/br-arm-cortex-a9-glibc/host/arm-buildroot-linux-gnueabihf/sysroot/usr/include/string.h:435:13: note: previous declaration of ‘explicit_bzero’ was here
 extern void explicit_bzero (void *__s, size_t __n) __THROW __nonnull ((1));
             ^~~~~~~~~~~~~~

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Petr Vorel 2019-05-21 07:56:44 +02:00 committed by Peter Korsgaard
parent 46ccd145f9
commit 252ad90833
3 changed files with 33 additions and 2 deletions

View File

@ -0,0 +1,28 @@
From dff595671bf5a46f7c9231966a6cd7d2a0183076 Mon Sep 17 00:00:00 2001
From: Marcel Holtmann <marcel@holtmann.org>
Date: Wed, 15 May 2019 09:39:44 +0200
Subject: [PATCH] build: Add check for explicit_bzero support
Upstream: dff595671bf5a46f7c9231966a6cd7d2a0183076
Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
---
configure.ac | 2 ++
1 file changed, 2 insertions(+)
diff --git a/configure.ac b/configure.ac
index bacb7ac5..cad35c5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,8 @@ AC_ARG_ENABLE(pie, AC_HELP_STRING([--enable-pie],
fi
])
+AC_CHECK_FUNCS(explicit_bzero)
+
AC_CHECK_FUNC(signalfd, dummy=yes,
AC_MSG_ERROR(signalfd support is required))
--
2.21.0

View File

@ -1,4 +1,4 @@
# From https://www.kernel.org/pub/linux/network/ofono/sha256sums.asc
sha256 93bb2cedef54f897dd5200e22b072a6e38b5d9b44be57eebbbe8d513f0beb0e4 ofono-1.28.tar.xz
sha256 67f0f8e5740dea5b46309e40667d1e560be39c90ef08dd01ff9e9ce8e61f0679 ofono-1.29.tar.xz
# Locally computed
sha256 e6d6a009505e345fe949e1310334fcb0747f28dae2856759de102ab66b722cb4 COPYING

View File

@ -4,7 +4,7 @@
#
################################################################################
OFONO_VERSION = 1.28
OFONO_VERSION = 1.29
OFONO_SOURCE = ofono-$(OFONO_VERSION).tar.xz
OFONO_SITE = $(BR2_KERNEL_MIRROR)/linux/network/ofono
OFONO_LICENSE = GPL-2.0
@ -49,4 +49,7 @@ else
OFONO_CONF_OPTS += --disable-bluetooth
endif
# required by 0003-build-Add-check-for-explicit_bzero-support.patch
OFONO_AUTORECONF = YES
$(eval $(autotools-package))