6186f01567
Patches were changed to git format, because libglib is a git project. 0003-gio-2.0.pc-include-libmount-in-Libs.private.patch was added to upstream as of commit: https://git.gnome.org/browse/glib/commit/?id=ecdd3c29fc4bd28f01fe53d0528bfee888c9c62c. Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
61 lines
1.7 KiB
Diff
61 lines
1.7 KiB
Diff
From ee2d6609bce808ac72afdbf86db1a6e27c78171e Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
|
|
Date: Wed, 21 Jun 2017 16:37:54 -0400
|
|
Subject: [PATCH] disable tests
|
|
|
|
Disable tests, some of them need python and sometimes host-python
|
|
gets mixed with distro python leading to build failures.
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
|
|
Signed-off-by: Adam Duskett <aduskett@codeblue.com>
|
|
---
|
|
Makefile.am | 2 +-
|
|
gio/Makefile.am | 2 +-
|
|
glib/Makefile.am | 4 ++--
|
|
3 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 008ad58..007332d 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -6,7 +6,7 @@ include $(top_srcdir)/glib.mk
|
|
|
|
ACLOCAL_AMFLAGS = -I m4macros ${ACLOCAL_FLAGS}
|
|
|
|
-SUBDIRS = . m4macros glib gmodule gthread gobject gio po docs tests
|
|
+SUBDIRS = . m4macros glib gmodule gthread gobject gio po docs
|
|
DIST_SUBDIRS = $(SUBDIRS) build win32
|
|
|
|
bin_SCRIPTS = glib-gettextize
|
|
diff --git a/gio/Makefile.am b/gio/Makefile.am
|
|
index 67db1b7..78309b5 100644
|
|
--- a/gio/Makefile.am
|
|
+++ b/gio/Makefile.am
|
|
@@ -244,7 +244,7 @@ platform_libadd += win32/libgiowin32.la
|
|
platform_deps += win32/libgiowin32.la
|
|
endif
|
|
|
|
-SUBDIRS += . tests
|
|
+SUBDIRS += .
|
|
|
|
if HAVE_FAM
|
|
SUBDIRS += fam
|
|
diff --git a/glib/Makefile.am b/glib/Makefile.am
|
|
index d755853..61166e5 100644
|
|
--- a/glib/Makefile.am
|
|
+++ b/glib/Makefile.am
|
|
@@ -33,8 +33,8 @@ else
|
|
MAYBE_PCRE = pcre
|
|
endif
|
|
|
|
-SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre . tests
|
|
-DIST_SUBDIRS = libcharset gnulib pcre update-pcre tests
|
|
+SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre .
|
|
+DIST_SUBDIRS = libcharset gnulib pcre update-pcre
|
|
|
|
AM_CPPFLAGS = \
|
|
$(glib_INCLUDES) \
|
|
--
|
|
2.9.4
|
|
|