libglib2: bump version to 2.52.2
Patches were changed to git format, because libglib is a git project. 0003-gio-2.0.pc-include-libmount-in-Libs.private.patch was added to upstream as of commit: https://git.gnome.org/browse/glib/commit/?id=ecdd3c29fc4bd28f01fe53d0528bfee888c9c62c. Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
568cc42f68
commit
6186f01567
@ -1,4 +1,7 @@
|
||||
[PATCH] Fix compilation issues on architectures with limited atomic support
|
||||
From d5c628a6179b99705fa05ab87437321b132c81bc Mon Sep 17 00:00:00 2001
|
||||
From: Brendan Heading <brendanheading@gmail.com>
|
||||
Date: Wed, 21 Jun 2017 16:36:15 -0400
|
||||
Subject: [PATCH] Fix compile time atomic detection
|
||||
|
||||
Improved compile-time detection of atomic support in the compiler.
|
||||
|
||||
@ -6,15 +9,16 @@ Upstream-Status: submitted
|
||||
See : https://bugzilla.gnome.org/show_bug.cgi?id=752731
|
||||
|
||||
Signed-off-by: Brendan Heading <brendanheading@gmail.com>
|
||||
Signed-off-by: Adam Duskett <aduskett@codeblue.com>
|
||||
---
|
||||
glib/gthread-posix.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/glib/gthread-posix.c b/glib/gthread-posix.c
|
||||
index ae5d805..8db8557 100644
|
||||
index 71a6b7b..d09d029 100644
|
||||
--- a/glib/gthread-posix.c
|
||||
+++ b/glib/gthread-posix.c
|
||||
@@ -67,7 +67,7 @@
|
||||
@@ -65,7 +65,7 @@
|
||||
#endif
|
||||
|
||||
/* clang defines __ATOMIC_SEQ_CST but doesn't support the GCC extension */
|
||||
@ -24,5 +28,5 @@ index ae5d805..8db8557 100644
|
||||
#endif
|
||||
|
||||
--
|
||||
2.4.3
|
||||
2.9.4
|
||||
|
||||
|
@ -1,12 +1,37 @@
|
||||
From ee2d6609bce808ac72afdbf86db1a6e27c78171e Mon Sep 17 00:00:00 2001
|
||||
From: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
|
||||
Date: Wed, 21 Jun 2017 16:37:54 -0400
|
||||
Subject: [PATCH] disable tests
|
||||
|
||||
Disable tests, some of them need python and sometimes host-python
|
||||
gets mixed with distro python leading to build failures.
|
||||
|
||||
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
|
||||
Signed-off-by: Adam Duskett <aduskett@codeblue.com>
|
||||
---
|
||||
Makefile.am | 2 +-
|
||||
gio/Makefile.am | 2 +-
|
||||
glib/Makefile.am | 4 ++--
|
||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff -Nura glib-2.46.1.orig/gio/Makefile.am glib-2.46.1/gio/Makefile.am
|
||||
--- glib-2.46.1.orig/gio/Makefile.am 2015-10-20 16:59:03.042212468 -0300
|
||||
+++ glib-2.46.1/gio/Makefile.am 2015-10-20 17:32:26.763146133 -0300
|
||||
@@ -233,7 +233,7 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 008ad58..007332d 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -6,7 +6,7 @@ include $(top_srcdir)/glib.mk
|
||||
|
||||
ACLOCAL_AMFLAGS = -I m4macros ${ACLOCAL_FLAGS}
|
||||
|
||||
-SUBDIRS = . m4macros glib gmodule gthread gobject gio po docs tests
|
||||
+SUBDIRS = . m4macros glib gmodule gthread gobject gio po docs
|
||||
DIST_SUBDIRS = $(SUBDIRS) build win32
|
||||
|
||||
bin_SCRIPTS = glib-gettextize
|
||||
diff --git a/gio/Makefile.am b/gio/Makefile.am
|
||||
index 67db1b7..78309b5 100644
|
||||
--- a/gio/Makefile.am
|
||||
+++ b/gio/Makefile.am
|
||||
@@ -244,7 +244,7 @@ platform_libadd += win32/libgiowin32.la
|
||||
platform_deps += win32/libgiowin32.la
|
||||
endif
|
||||
|
||||
@ -15,10 +40,11 @@ diff -Nura glib-2.46.1.orig/gio/Makefile.am glib-2.46.1/gio/Makefile.am
|
||||
|
||||
if HAVE_FAM
|
||||
SUBDIRS += fam
|
||||
diff -Nura glib-2.46.1.orig/glib/Makefile.am glib-2.46.1/glib/Makefile.am
|
||||
--- glib-2.46.1.orig/glib/Makefile.am 2015-10-20 16:59:03.066213318 -0300
|
||||
+++ glib-2.46.1/glib/Makefile.am 2015-10-20 17:33:23.537155988 -0300
|
||||
@@ -33,8 +33,8 @@
|
||||
diff --git a/glib/Makefile.am b/glib/Makefile.am
|
||||
index d755853..61166e5 100644
|
||||
--- a/glib/Makefile.am
|
||||
+++ b/glib/Makefile.am
|
||||
@@ -33,8 +33,8 @@ else
|
||||
MAYBE_PCRE = pcre
|
||||
endif
|
||||
|
||||
@ -29,15 +55,6 @@ diff -Nura glib-2.46.1.orig/glib/Makefile.am glib-2.46.1/glib/Makefile.am
|
||||
|
||||
AM_CPPFLAGS = \
|
||||
$(glib_INCLUDES) \
|
||||
diff -Nura glib-2.46.1.orig/Makefile.am glib-2.46.1/Makefile.am
|
||||
--- glib-2.46.1.orig/Makefile.am 2015-10-20 16:59:03.003211087 -0300
|
||||
+++ glib-2.46.1/Makefile.am 2015-10-20 17:32:20.923939420 -0300
|
||||
@@ -6,7 +6,7 @@
|
||||
|
||||
ACLOCAL_AMFLAGS = -I m4macros ${ACLOCAL_FLAGS}
|
||||
|
||||
-SUBDIRS = . m4macros glib gmodule gthread gobject gio po docs tests
|
||||
+SUBDIRS = . m4macros glib gmodule gthread gobject gio po docs
|
||||
DIST_SUBDIRS = $(SUBDIRS) build
|
||||
|
||||
bin_SCRIPTS = glib-gettextize
|
||||
--
|
||||
2.9.4
|
||||
|
||||
|
@ -1,32 +0,0 @@
|
||||
From ee32416dec8462ee27c3c254100cf980b0889ce0 Mon Sep 17 00:00:00 2001
|
||||
From: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
|
||||
Date: Tue, 18 Oct 2016 23:04:50 +0530
|
||||
Subject: [PATCH] gio-2.0.pc: include libmount in Libs.private
|
||||
|
||||
This helps with static linking. When application statically links with
|
||||
libgio, it needs to link against libmount explicitly. When it is
|
||||
mentioned in Libs.private, build system can figure out with which extra
|
||||
libs to link against with help of pkg-config.
|
||||
|
||||
This build failure is detected by Buildroot autobuilder:
|
||||
http://autobuild.buildroot.net/results/fdf/fdf26abbed0014606a7788ce5d60828a0e871186
|
||||
|
||||
Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
|
||||
---
|
||||
gio-2.0.pc.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gio-2.0.pc.in b/gio-2.0.pc.in
|
||||
index 899af0c..7574eb7 100644
|
||||
--- a/gio-2.0.pc.in
|
||||
+++ b/gio-2.0.pc.in
|
||||
@@ -14,5 +14,5 @@ Version: @VERSION@
|
||||
Requires: glib-2.0 gobject-2.0
|
||||
Requires.private: gmodule-no-export-2.0
|
||||
Libs: -L${libdir} -lgio-2.0
|
||||
-Libs.private: @ZLIB_LIBS@ @NETWORK_LIBS@ @SELINUX_LIBS@ @COCOA_LIBS@ @CARBON_LIBS@
|
||||
+Libs.private: @ZLIB_LIBS@ @NETWORK_LIBS@ @SELINUX_LIBS@ @COCOA_LIBS@ @CARBON_LIBS@ @LIBMOUNT_LIBS@
|
||||
Cflags:
|
||||
--
|
||||
2.6.2
|
||||
|
@ -1,2 +1,2 @@
|
||||
# https://download.gnome.org/sources/glib/2.50/glib-2.50.3.sha256sum
|
||||
sha256 82ee94bf4c01459b6b00cb9db0545c2237921e3060c0b74cff13fbc020cfd999 glib-2.50.3.tar.xz
|
||||
# https://download.gnome.org/sources/glib/2.50/glib-2.52.2.sha256sum
|
||||
sha256 f00e5d9e2a2948b1da25fcba734a6b7a40f556de8bc9f528a53f6569969ac5d0 glib-2.52.2.tar.xz
|
||||
|
@ -4,8 +4,8 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBGLIB2_VERSION_MAJOR = 2.50
|
||||
LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).3
|
||||
LIBGLIB2_VERSION_MAJOR = 2.52
|
||||
LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).2
|
||||
LIBGLIB2_SOURCE = glib-$(LIBGLIB2_VERSION).tar.xz
|
||||
LIBGLIB2_SITE = http://ftp.gnome.org/pub/gnome/sources/glib/$(LIBGLIB2_VERSION_MAJOR)
|
||||
LIBGLIB2_LICENSE = LGPL-2.0+
|
||||
|
Loading…
Reference in New Issue
Block a user