package/kmsxx: update to latest

We can drop all the patches as they have been sorted out in upstream.

The wrapped fmt was dropped, so drop the corresponding option.

The option to use a system pybind11 was named differently upstream, as a
feature rather as a boolean. Adapt accordingly.

Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com>
[yann.morin.1998@free.fr: explain dropped/changed options]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Tomi Valkeinen 2021-08-06 15:50:47 +03:00 committed by Yann E. MORIN
parent 95ad161fe9
commit ecb72b118a
5 changed files with 3 additions and 141 deletions

View File

@ -1,46 +0,0 @@
From 61db7d5520f50564da8f2c9ac952eadb31f70727 Mon Sep 17 00:00:00 2001
From: Peter Seiderer <ps.report@gmx.net>
Date: Sun, 29 Nov 2020 11:13:41 +0100
Subject: [PATCH] meson: add use-system-fmt option
[Upstream: https://github.com/tomba/kmsxx/pull/60]
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
meson.build | 10 +++++++---
meson_options.txt | 2 ++
2 files changed, 9 insertions(+), 3 deletions(-)
diff --git a/meson.build b/meson.build
index 9652009..29080f4 100644
--- a/meson.build
+++ b/meson.build
@@ -31,9 +31,13 @@ endif
add_global_link_arguments(link_arguments, language : 'cpp')
-libfmt_includes = include_directories('ext/fmt/include')
-libfmt_dep = declare_dependency(include_directories : libfmt_includes,
- compile_args : '-DFMT_HEADER_ONLY')
+if get_option('use-system-fmt')
+ libfmt_dep = dependency('fmt')
+else
+ libfmt_includes = include_directories('ext/fmt/include')
+ libfmt_dep = declare_dependency(include_directories : libfmt_includes,
+ compile_args : '-DFMT_HEADER_ONLY')
+endif
pybind11_includes = include_directories('ext/pybind11/include')
pybind11_dep = declare_dependency(include_directories : pybind11_includes)
diff --git a/meson_options.txt b/meson_options.txt
index cd854ab..48176a8 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -3,3 +3,5 @@ option('pykms', type : 'feature', value : 'auto')
option('omap', type : 'feature', value : 'auto')
option('static-libc', type : 'boolean', value : false)
option('utils', type : 'boolean', value : true)
+
+option('use-system-fmt', type : 'boolean', value : false)
--
2.29.2

View File

@ -1,43 +0,0 @@
From 27f15549ce67194e4152c57db2b762b7a443b4c7 Mon Sep 17 00:00:00 2001
From: Peter Seiderer <ps.report@gmx.net>
Date: Sun, 29 Nov 2020 11:14:41 +0100
Subject: [PATCH] meson: add use-system-pybind11 option
[Upstream: https://github.com/tomba/kmsxx/pull/60]
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
meson.build | 8 ++++++--
meson_options.txt | 1 +
2 files changed, 7 insertions(+), 2 deletions(-)
diff --git a/meson.build b/meson.build
index 29080f4..4b3e7c3 100644
--- a/meson.build
+++ b/meson.build
@@ -39,8 +39,12 @@ else
compile_args : '-DFMT_HEADER_ONLY')
endif
-pybind11_includes = include_directories('ext/pybind11/include')
-pybind11_dep = declare_dependency(include_directories : pybind11_includes)
+if get_option('use-system-pybind11')
+ pybind11_dep = dependency('pybind11')
+else
+ pybind11_includes = include_directories('ext/pybind11/include')
+ pybind11_dep = declare_dependency(include_directories : pybind11_includes)
+endif
libdrmomap_dep = dependency('libdrm_omap', required : get_option('omap'))
diff --git a/meson_options.txt b/meson_options.txt
index 48176a8..095c6f2 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -5,3 +5,4 @@ option('static-libc', type : 'boolean', value : false)
option('utils', type : 'boolean', value : true)
option('use-system-fmt', type : 'boolean', value : false)
+option('use-system-pybind11', type : 'boolean', value : false)
--
2.29.2

View File

@ -1,48 +0,0 @@
From 0ef36b2e22c2ac0331b3096b7adc69fb08044048 Mon Sep 17 00:00:00 2001
From: Peter Seiderer <ps.report@gmx.net>
Date: Sun, 29 Nov 2020 11:37:26 +0100
Subject: [PATCH] meson: only build py in case pykms is enabled
[Upstream: https://github.com/tomba/kmsxx/pull/60]
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
meson.build | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
diff --git a/meson.build b/meson.build
index 4b3e7c3..1810b17 100644
--- a/meson.build
+++ b/meson.build
@@ -39,11 +39,13 @@ else
compile_args : '-DFMT_HEADER_ONLY')
endif
-if get_option('use-system-pybind11')
- pybind11_dep = dependency('pybind11')
-else
- pybind11_includes = include_directories('ext/pybind11/include')
- pybind11_dep = declare_dependency(include_directories : pybind11_includes)
+if get_option('pykms').enabled()
+ if get_option('use-system-pybind11')
+ pybind11_dep = dependency('pybind11')
+ else
+ pybind11_includes = include_directories('ext/pybind11/include')
+ pybind11_dep = declare_dependency(include_directories : pybind11_includes)
+ endif
endif
libdrmomap_dep = dependency('libdrm_omap', required : get_option('omap'))
@@ -55,7 +57,9 @@ if get_option('utils')
subdir('utils')
endif
-subdir('py')
+if get_option('pykms').enabled()
+ subdir('py')
+endif
if get_option('kmscube')
subdir('kmscube')
--
2.29.2

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 4a682328b03c28ff1f6cfcafc48d30c3feb5ef98ed07e5dd3bbd9e6a1d4a47cc kmsxx-548905611c130ea9d31929a0caf7a198d8bac462.tar.gz
sha256 99759fe9334369ccd80ab0bbfe1110ee47e74f1e20abc2d7b2f028067ea0a0c3 kmsxx-824bbb1f4cd062d66b457faca50f904b34dfd96c.tar.gz
sha256 fab3dd6bdab226f1c08630b1dd917e11fcb4ec5e1e020e2c16f83a0a13863e85 LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
KMSXX_VERSION = 548905611c130ea9d31929a0caf7a198d8bac462
KMSXX_VERSION = 824bbb1f4cd062d66b457faca50f904b34dfd96c
KMSXX_SITE = $(call github,tomba,kmsxx,$(KMSXX_VERSION))
KMSXX_LICENSE = MPL-2.0
KMSXX_LICENSE_FILES = LICENSE
@ -14,8 +14,7 @@ KMSXX_CONF_OPTS = \
-Dkmscube=false \
-Dpykms=disabled \
-Domap=disabled \
-Duse-system-fmt=true \
-Duse-system-pybind11=true
-Dsystem-pybind11=enabled
ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
KMSXX_CXXFLAGS += $(TARGET_CXXFLAGS) -O0