Add dnsmasq1 (currently 1.18). Eventually I'll also add dnsmasq2.

The patch makes it respect current uClibc ipv6 configuration.
This commit is contained in:
Manuel Novoa III 2004-03-05 19:03:17 +00:00
parent 6cf315cd23
commit de40cc62a0
2 changed files with 53 additions and 0 deletions

41
make/dnsmasq1.mk Normal file
View File

@ -0,0 +1,41 @@
#############################################################
#
# dnsmasq1
#
#############################################################
DNSMASQ1_SOURCE=dnsmasq-1.18.tar.gz
DNSMASQ1_SITE=http://thekelleys.org.uk/dnsmasq
DNSMASQ1_DIR=$(BUILD_DIR)/dnsmasq-1.18
DNSMASQ1_BINARY=dnsmasq
DNSMASQ1_TARGET_BINARY=usr/sbin/dnsmasq
$(DL_DIR)/$(DNSMASQ1_SOURCE):
$(WGET) -P $(DL_DIR) $(DNSMASQ1_SITE)/$(DNSMASQ1_SOURCE)
$(DNSMASQ1_DIR)/.source: $(DL_DIR)/$(DNSMASQ1_SOURCE)
zcat $(DL_DIR)/$(DNSMASQ1_SOURCE) | tar -C $(BUILD_DIR) -xvf -
patch -p1 -d $(DNSMASQ1_DIR) < $(SOURCE_DIR)/dnsmasq1.patch
touch $(DNSMASQ1_DIR)/.source
$(DNSMASQ1_DIR)/$(DNSMASQ1_BINARY): $(DNSMASQ1_DIR)/.source
$(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
BINDIR=/usr/sbin MANDIR=/usr/man -C $(DNSMASQ1_DIR)
$(TARGET_DIR)/$(DNSMASQ1_TARGET_BINARY): $(DNSMASQ1_DIR)/$(DNSMASQ1_BINARY)
$(MAKE) BINDIR=/usr/sbin MANDIR=/usr/man \
DESTDIR=$(TARGET_DIR) -C $(DNSMASQ1_DIR) install
$(STRIP) $(TARGET_DIR)/$(DNSMASQ1_TARGET_BINARY)
rm -Rf $(TARGET_DIR)/usr/man
dnsmasq1: uclibc $(TARGET_DIR)/$(DNSMASQ1_TARGET_BINARY)
dnsmasq1-source: $(DL_DIR)/$(DNSMASQ1_SOURCE)
dnsmasq1-clean:
#$(MAKE) prefix=$(TARGET_DIR)/usr -C $(DNSMASQ1_DIR) uninstall
-$(MAKE) -C $(DNSMASQ1_DIR) clean
dnsmasq1-dirclean:
rm -rf $(DNSMASQ1_DIR)

12
sources/dnsmasq1.patch Normal file
View File

@ -0,0 +1,12 @@
--- dnsmasq-1.18/config.h.dist 2004-03-01 22:25:12.000000000 -0600
+++ dnsmasq-1.18/config.h 2004-03-01 22:26:50.000000000 -0600
@@ -126,7 +126,9 @@
/* Must preceed __linux__ since uClinux defines __linux__ too. */
#if defined(__uClinux__) || defined(__UCLIBC__)
+#ifndef __UCLIBC_HAS_IPV6__
#undef HAVE_LINUX_IPV6_PROC
+#endif
#define HAVE_GETOPT_LONG
#undef HAVE_ARC4RANDOM
#define HAVE_RANDOM