Clean up makefile. Don't install (legacy?) brctld app since debian doesn't.
Fix paths. Add a patch to respect CFLAGS. Fix buildroot kernel location.
This commit is contained in:
parent
e8676aedf3
commit
6cf315cd23
@ -7,6 +7,7 @@
|
||||
BRIDGE_SOURCE_URL=http://bridge.sourceforge.net/bridge-utils
|
||||
BRIDGE_SOURCE=bridge-utils-0.9.6.tar.gz
|
||||
BRIDGE_BUILD_DIR=$(BUILD_DIR)/bridge-utils-0.9.6
|
||||
BRIDGE_TARGET_BINARY:=usr/sbin/brctl
|
||||
|
||||
$(DL_DIR)/$(BRIDGE_SOURCE):
|
||||
$(WGET) -P $(DL_DIR) $(BRIDGE_SOURCE_URL)/$(BRIDGE_SOURCE)
|
||||
@ -14,6 +15,7 @@ $(DL_DIR)/$(BRIDGE_SOURCE):
|
||||
$(BRIDGE_BUILD_DIR)/.unpacked: $(DL_DIR)/$(BRIDGE_SOURCE)
|
||||
zcat $(DL_DIR)/$(BRIDGE_SOURCE) | tar -C $(BUILD_DIR) -xvf -
|
||||
mv -f $(BUILD_DIR)/bridge-utils $(BRIDGE_BUILD_DIR)
|
||||
patch -p1 -d $(BRIDGE_BUILD_DIR) < $(SOURCE_DIR)/bridge.patch
|
||||
touch $(BRIDGE_BUILD_DIR)/.unpacked
|
||||
|
||||
$(BRIDGE_BUILD_DIR)/.configured: $(BRIDGE_BUILD_DIR)/.unpacked
|
||||
@ -35,23 +37,25 @@ $(BRIDGE_BUILD_DIR)/.configured: $(BRIDGE_BUILD_DIR)/.unpacked
|
||||
--mandir=/usr/man \
|
||||
--infodir=/usr/info \
|
||||
$(DISABLE_NLS) \
|
||||
--with-linux-headers=$(BUILD_DIR)/linux \
|
||||
--with-linux=$(LINUX_DIR) \
|
||||
);
|
||||
touch $(BRIDGE_BUILD_DIR)/.configured
|
||||
|
||||
$(BRIDGE_BUILD_DIR)/brctl/brctl: $(BRIDGE_BUILD_DIR)/.configured
|
||||
$(MAKE) -C $(BRIDGE_BUILD_DIR)
|
||||
|
||||
$(TARGET_DIR)/sbin/brctl: $(BRIDGE_BUILD_DIR)/brctl/brctl
|
||||
cp -af $(BRIDGE_BUILD_DIR)/brctl/brctl $(TARGET_DIR)/sbin/
|
||||
cp -af $(BRIDGE_BUILD_DIR)/brctl/brctld $(TARGET_DIR)/sbin/
|
||||
$(TARGET_DIR)/$(BRIDGE_TARGET_BINARY): $(BRIDGE_BUILD_DIR)/brctl/brctl
|
||||
cp -af $(BRIDGE_BUILD_DIR)/brctl/brctl $(TARGET_DIR)/$(BRIDGE_TARGET_BINARY)
|
||||
$(STRIP) $(TARGET_DIR)/$(BRIDGE_TARGET_BINARY)
|
||||
#cp -af $(BRIDGE_BUILD_DIR)/brctl/brctld $(TARGET_DIR)/usr/sbin/
|
||||
#$(STRIP) $(TARGET_DIR)/usr/sbin/brctld
|
||||
|
||||
bridge: $(TARGET_DIR)/sbin/brctl
|
||||
bridge: $(TARGET_DIR)/$(BRIDGE_TARGET_BINARY)
|
||||
|
||||
bridge-source: $(DL_DIR)/$(BRIDGE_SOURCE)
|
||||
|
||||
bridge-clean:
|
||||
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BRIDGE_BUILD_DIR) uninstall
|
||||
#$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BRIDGE_BUILD_DIR) uninstall
|
||||
-$(MAKE) -C $(BRIDGE_BUILD_DIR) clean
|
||||
|
||||
bridge-dirclean:
|
||||
|
11
sources/bridge.patch
Normal file
11
sources/bridge.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- bridge-utils-0.9.6/libbridge/Makefile.in.dist 2004-03-01 20:55:52.000000000 -0600
|
||||
+++ bridge-utils-0.9.6/libbridge/Makefile.in 2004-03-01 20:56:23.000000000 -0600
|
||||
@@ -5,7 +5,7 @@
|
||||
RANLIB=@RANLIB@
|
||||
|
||||
CC=@CC@
|
||||
-CFLAGS = -Wall -g $(KERNEL_HEADERS)
|
||||
+CFLAGS = -Wall -g @CFLAGS@ $(KERNEL_HEADERS)
|
||||
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
Loading…
Reference in New Issue
Block a user