package/wine: bump to version 7.0

Multiple library checks are obsolete, either due to removal or due to built-in solutions.

License file changed due to update of copyright year.

Signed-off-by: André Zwing <nerv@dawncrow.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
André Zwing 2022-06-07 15:18:51 +02:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 825b563716
commit da6b2c2df0
4 changed files with 46 additions and 68 deletions

View File

@ -0,0 +1,21 @@
commit 75b70efdaa2d4baa064271098878b79f66df155f
Author: André Zwing <nerv@dawncrow.de>
Date: Sat May 21 17:53:07 2022 +0200
l3codeca.acm: Avoid mpg123 functions with suffix.
[Upstream commit: https://source.winehq.org/git/wine.git/commit/75b70efdaa2d4baa064271098878b79f66df155f]
Signed-off-by: André Zwing <nerv@dawncrow.de>
diff --git a/dlls/l3codeca.acm/Makefile.in b/dlls/l3codeca.acm/Makefile.in
index 451794b2624..31765766d4e 100644
--- a/dlls/l3codeca.acm/Makefile.in
+++ b/dlls/l3codeca.acm/Makefile.in
@@ -1,6 +1,7 @@
MODULE = l3codeca.acm
IMPORTS = $(MPG123_PE_LIBS) winmm user32 kernelbase
EXTRAINCL = $(MPG123_PE_CFLAGS)
+EXTRADEFS = -DMPG123_NO_LARGENAME
C_SRCS = \
mpegl3.c

View File

@ -0,0 +1,21 @@
commit 8d441659f7c7ae359e06a99e7abaae57792356a0
Author: André Zwing <nerv@dawncrow.de>
Date: Sat May 21 17:53:07 2022 +0200
mp3dmod: Avoid mpg123 functions with suffix.
[Upstream commit: https://source.winehq.org/git/wine.git/commit/8d441659f7c7ae359e06a99e7abaae57792356a0]
Signed-off-by: André Zwing <nerv@dawncrow.de>
diff --git a/dlls/mp3dmod/Makefile.in b/dlls/mp3dmod/Makefile.in
index dabbb1dfeae..3ba343a4d34 100644
--- a/dlls/mp3dmod/Makefile.in
+++ b/dlls/mp3dmod/Makefile.in
@@ -1,6 +1,7 @@
MODULE = mp3dmod.dll
IMPORTS = $(MPG123_PE_LIBS) dmoguids msdmo ole32 uuid wmcodecdspuuid kernelbase
EXTRAINCL = $(MPG123_PE_CFLAGS)
+EXTRADEFS = -DMPG123_NO_LARGENAME
C_SRCS = \
mp3dmod.c

View File

@ -1,5 +1,5 @@
# Locally calculated after checking pgp signature
sha256 b493065f2f83ee429c62e2ec58698a3cf63ef78722e1b20765823152e8582c56 wine-6.0.tar.xz
sha256 5b43e27d5c085cb18f97394e46180310d5eef7c1d91c6895432a3889b2de086b wine-7.0.tar.xz
# Locally calculated
sha256 e237fa56668030e928551ddd60f05df5fe957f75eab874bbd017e085ed722e7c COPYING.LIB
sha256 111398f1be25b1ae1f124512fe61569e6b4555408e2feb9bc82f9fe57d39b302 LICENSE
sha256 7c360930e51d56c8fa12fe1df8ed348ac77a9ad73f9582a303919469399b3ce4 LICENSE

View File

@ -4,9 +4,9 @@
#
################################################################################
WINE_VERSION = 6.0
WINE_VERSION = 7.0
WINE_SOURCE = wine-$(WINE_VERSION).tar.xz
WINE_SITE = https://dl.winehq.org/wine/source/6.0
WINE_SITE = https://dl.winehq.org/wine/source/7.0
WINE_LICENSE = LGPL-2.1+
WINE_LICENSE_FILES = COPYING.LIB LICENSE
WINE_CPE_ID_VENDOR = winehq
@ -21,12 +21,9 @@ WINE_CONF_OPTS = \
--disable-win64 \
--without-capi \
--without-coreaudio \
--without-faudio \
--without-gettext \
--without-gettextpo \
--without-gphoto \
--without-gsm \
--without-hal \
--without-mingw \
--without-opencl \
--without-oss \
@ -99,20 +96,6 @@ else
WINE_CONF_OPTS += --without-gstreamer
endif
ifeq ($(BR2_PACKAGE_JPEG),y)
WINE_CONF_OPTS += --with-jpeg
WINE_DEPENDENCIES += jpeg
else
WINE_CONF_OPTS += --without-jpeg
endif
ifeq ($(BR2_PACKAGE_LCMS2),y)
WINE_CONF_OPTS += --with-cms
WINE_DEPENDENCIES += lcms2
else
WINE_CONF_OPTS += --without-cms
endif
ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
WINE_CONF_OPTS += --with-opengl
WINE_DEPENDENCIES += libgl
@ -134,13 +117,6 @@ else
WINE_CONF_OPTS += --without-pcap
endif
ifeq ($(BR2_PACKAGE_LIBPNG),y)
WINE_CONF_OPTS += --with-png
WINE_DEPENDENCIES += libpng
else
WINE_CONF_OPTS += --without-png
endif
ifeq ($(BR2_PACKAGE_LIBUSB),y)
WINE_CONF_OPTS += --with-usb
WINE_DEPENDENCIES += libusb
@ -155,29 +131,6 @@ else
WINE_CONF_OPTS += --without-v4l2
endif
ifeq ($(BR2_PACKAGE_LIBXML2),y)
WINE_CONF_OPTS += --with-xml
WINE_DEPENDENCIES += libxml2
WINE_CONF_ENV += XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
else
WINE_CONF_OPTS += --without-xml
endif
ifeq ($(BR2_PACKAGE_LIBXSLT),y)
WINE_CONF_OPTS += --with-xslt
WINE_DEPENDENCIES += libxslt
WINE_CONF_ENV += XSLT_CONFIG=$(STAGING_DIR)/usr/bin/xslt-config
else
WINE_CONF_OPTS += --without-xslt
endif
ifeq ($(BR2_PACKAGE_MPG123),y)
WINE_CONF_OPTS += --with-mpg123
WINE_DEPENDENCIES += mpg123
else
WINE_CONF_OPTS += --without-mpg123
endif
ifeq ($(BR2_PACKAGE_OPENAL),y)
WINE_CONF_OPTS += --with-openal
WINE_DEPENDENCIES += openal
@ -228,13 +181,6 @@ else
WINE_CONF_OPTS += --without-sdl
endif
ifeq ($(BR2_PACKAGE_TIFF),y)
WINE_CONF_OPTS += --with-tiff
WINE_DEPENDENCIES += tiff
else
WINE_CONF_OPTS += --without-tiff
endif
ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
WINE_CONF_OPTS += --with-udev
WINE_DEPENDENCIES += udev
@ -349,23 +295,17 @@ HOST_WINE_CONF_OPTS += \
--disable-win16 \
--without-alsa \
--without-capi \
--without-cms \
--without-coreaudio \
--without-faudio \
--without-cups \
--without-dbus \
--without-fontconfig \
--without-gphoto \
--without-gnutls \
--without-gsm \
--without-gssapi \
--without-gstreamer \
--without-hal \
--without-jpeg \
--without-krb5 \
--without-ldap \
--without-mingw \
--without-mpg123 \
--without-netapi \
--without-openal \
--without-opencl \
@ -374,10 +314,8 @@ HOST_WINE_CONF_OPTS += \
--without-oss \
--without-pcap \
--without-pulse \
--without-png \
--without-sane \
--without-sdl \
--without-tiff \
--without-usb \
--without-v4l2 \
--without-vkd3d \
@ -388,12 +326,10 @@ HOST_WINE_CONF_OPTS += \
--without-xinerama \
--without-xinput \
--without-xinput2 \
--without-xml \
--without-xrandr \
--without-xrender \
--without-xshape \
--without-xshm \
--without-xslt \
--without-xxf86vm
$(eval $(autotools-package))