package/librtas: bump to v2.0.3
Includes build fixes for musl, so remove the glibc restriction, as it now builds fine for both musl and uclibc. Signed-off-by: Joel Stanley <joel@jms.id.au> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
dad510abd1
commit
825b563716
@ -0,0 +1,46 @@
|
||||
From 148712f8a559cc613236e9e72b3ce6c24b83c373 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
Date: Sat, 23 Jul 2022 18:51:37 +0200
|
||||
Subject: [PATCH] configure.ac: remove LOCAL_CHECK_FLAGS
|
||||
|
||||
These cause problems with Buildroot (the -fstack-protector-all check
|
||||
does only a compile test, it should do a link test), and generally the
|
||||
decision of using those flags or not should be left to Buildroot.
|
||||
|
||||
An issue has been reported upstream at
|
||||
https://github.com/ibm-power-utilities/librtas/issues/25 to hopefully
|
||||
get a better solution.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
---
|
||||
configure.ac | 14 --------------
|
||||
1 file changed, 14 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index c3429e8..b7208ee 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -24,20 +24,6 @@ AC_TYPE_UID_T
|
||||
AC_TYPE_UINT32_T
|
||||
AC_TYPE_UINT64_T
|
||||
|
||||
-AC_DEFUN([LOCAL_CHECK_FLAGS],[
|
||||
- AC_REQUIRE([AX_CHECK_LINK_FLAG])
|
||||
- AC_REQUIRE([AX_APPEND_COMPILE_FLAGS])
|
||||
- AC_LANG_PUSH([C])
|
||||
- AX_APPEND_COMPILE_FLAGS([-Wall])
|
||||
- AX_APPEND_COMPILE_FLAGS([-D_FORTIFY_SOURCE=2 -fstack-protector-all])
|
||||
- AX_APPEND_COMPILE_FLAGS([-fwrapv -fPIE -Wstack-protector])
|
||||
- AX_APPEND_COMPILE_FLAGS([--param=ssp-buffer-size=1])
|
||||
- AX_CHECK_LINK_FLAG([-z relro -z now])
|
||||
- AX_CHECK_LINK_FLAG([-pie])
|
||||
- AC_LANG_POP
|
||||
-])
|
||||
-LOCAL_CHECK_FLAGS
|
||||
-
|
||||
LT_INIT
|
||||
LT_LANG([C])
|
||||
|
||||
--
|
||||
2.37.1
|
||||
|
@ -1,7 +1,6 @@
|
||||
config BR2_PACKAGE_LIBRTAS
|
||||
bool "librtas"
|
||||
depends on BR2_powerpc || BR2_powerpc64 || BR2_powerpc64le
|
||||
depends on BR2_TOOLCHAIN_USES_GLIBC
|
||||
help
|
||||
The librtas package provides an interface for Run-Time
|
||||
Abstraction Services (RTAS) calls on PAPR platforms.
|
||||
@ -9,7 +8,3 @@ config BR2_PACKAGE_LIBRTAS
|
||||
and parse RTAS events.
|
||||
|
||||
http://librtas.sourceforge.net/
|
||||
|
||||
comment "librtas needs a glibc toolchain"
|
||||
depends on BR2_powerpc || BR2_powerpc64 || BR2_powerpc64le
|
||||
depends on !BR2_TOOLCHAIN_USES_GLIBC
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally computed
|
||||
sha256 b47b2a6f140347ac265e2c66ddf68293f6cdcc7c0c9a78c6e21ff52846465415 librtas-2.0.2.tar.gz
|
||||
sha256 1b951422ec9553fa9d5e5e158fd8e298f867f561189fff6817a9540d5661f145 librtas-2.0.3.tar.gz
|
||||
sha256 592987e8510228d546540b84a22444bde98e48d03078d3b2eefcd889bec5ce8c COPYING.LESSER
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBRTAS_VERSION = 2.0.2
|
||||
LIBRTAS_VERSION = 2.0.3
|
||||
LIBRTAS_SITE = $(call github,ibm-power-utilities,librtas,v$(LIBRTAS_VERSION))
|
||||
LIBRTAS_LICENSE = LGPL-2.1+
|
||||
LIBRTAS_LICENSE_FILES = COPYING.LESSER
|
||||
|
Loading…
Reference in New Issue
Block a user