evemu: bump version to 1.2.0

[Peter: add patches for modern kernel headers and to disable tests]
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Peter Seiderer 2014-04-22 23:47:17 +02:00 committed by Peter Korsgaard
parent 83114f4552
commit 7e80e93906
3 changed files with 45 additions and 1 deletions

View File

@ -0,0 +1,25 @@
[PATCH] make-event-names.py: fix SYN_MAX definition for modern kernel headers
SYN_MAX has been exported to user space since 3.12 (52764fed5: Input: add
SYN_MAX and SYN_CNT constants), so only define it locally if not already
defined, otherwise the build breaks.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
src/make-event-names.py | 2 ++
1 file changed, 2 insertions(+)
Index: evemu-1.2.0/src/make-event-names.py
===================================================================
--- evemu-1.2.0.orig/src/make-event-names.py
+++ evemu-1.2.0/src/make-event-names.py
@@ -91,7 +91,9 @@
print "#ifndef EVENT_NAMES_H"
print "#define EVENT_NAMES_H"
print ""
+ print "#ifndef SYN_MAX"
print "#define SYN_MAX 3 /* linux/input.h doesn't define that */"
+ print "#endif"
print ""
for prefix in prefixes:

View File

@ -0,0 +1,19 @@
[PATCH] disable tests
The tests need C++ support and add to build time, so disable them for BR.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: evemu-1.2.0/Makefile.am
===================================================================
--- evemu-1.2.0.orig/Makefile.am
+++ evemu-1.2.0/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = src tools python test
+SUBDIRS = src tools python
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = evemu.pc

View File

@ -4,7 +4,7 @@
#
################################################################################
EVEMU_VERSION = 1.0.10
EVEMU_VERSION = 1.2.0
EVEMU_SITE = http://cgit.freedesktop.org/evemu/snapshot
EVEMU_LICENSE = LGPLv3 (library), GPLv3 (tools)
EVEMU_LICENSE_FILES = COPYING COPYING.GPL3