Revert "package/python3: fix install when tk is disabled"

This reverts commit 687b96db4d.

Python 3.12 is still causing too many build failures, so revert for 2024.02.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Peter Korsgaard 2024-02-24 11:33:11 +01:00
parent a4a0ecacea
commit 7bae4ea6ee

View File

@ -62,7 +62,7 @@ diff --git a/configure.ac b/configure.ac
index c8ae60aa6b5..7caa361138d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4503,6 +4503,13 @@ AC_ARG_ENABLE(pydoc,
@@ -4503,6 +4503,11 @@ AC_ARG_ENABLE(pydoc,
AS_HELP_STRING([--disable-pydoc], [disable pydoc]),
[ PYDOC="${enableval}" ], [ PYDOC=yes ])
@ -70,8 +70,6 @@ index c8ae60aa6b5..7caa361138d 100644
+AC_ARG_ENABLE(tk,
+ AS_HELP_STRING([--disable-tk], [disable tk]),
+ [ TK="${enableval}" ], [ TK=yes ])
+AS_IF([test "$TK" = "no"],
+ [PY_STDLIB_MOD_SET_NA([_tkinter])])
+
# Check for enable-ipv6
AH_TEMPLATE([ENABLE_IPV6], [Define if --enable-ipv6 is specified])