package/python3: fix install when tk is disabled
Fixes the following failure in the install step of host-python3:
...
/usr/bin/install -c -m 644 pyconfig.h output/host/include/python3.12/pyconfig.h
[ERROR] _tkinter failed to import: output/build/host-python3-3.12.1/build/lib.linux-x86_64-3.12/_tkinter.cpython-312-x86_64-linux-gnu.so: undefined symbol: Tcl_AddErrorInfo
The following modules are *disabled* in configure script:
_ctypes_test _testbuffer _testcapi
_testclinic _testimportmultiple _testinternalcapi
_testmultiphase _xxtestfuzz xxsubtype
Following modules built successfully but were removed because they could not be imported:
_tkinter
Checked 110 modules (31 built-in, 54 shared, 15 n/a on linux-x86_64, 9 disabled, 0 missing, 1 failed on import)
...
/usr/bin/install -c -m 644 ./Lib/types.py output/host/lib/python3.12
/usr/bin/install: cannot stat 'Modules/_tkinter.cpython-312-x86_64-linux-gnu.so': No such file or directory
/usr/bin/install -c -m 644 ./Lib/typing.py output/host/lib/python3.12
make[3]: *** [Makefile:2068: sharedinstall] Error 1
...
Fixes: 36e635d2d5
("package/python3: bump version to 3.12.1")
Signed-off-by: Roy Kollen Svendsen <roy.kollen.svendsen@akersolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
d4abcf5872
commit
687b96db4d
@ -62,7 +62,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index c8ae60aa6b5..7caa361138d 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4503,6 +4503,11 @@ AC_ARG_ENABLE(pydoc,
|
||||
@@ -4503,6 +4503,13 @@ AC_ARG_ENABLE(pydoc,
|
||||
AS_HELP_STRING([--disable-pydoc], [disable pydoc]),
|
||||
[ PYDOC="${enableval}" ], [ PYDOC=yes ])
|
||||
|
||||
@ -70,6 +70,8 @@ index c8ae60aa6b5..7caa361138d 100644
|
||||
+AC_ARG_ENABLE(tk,
|
||||
+ AS_HELP_STRING([--disable-tk], [disable tk]),
|
||||
+ [ TK="${enableval}" ], [ TK=yes ])
|
||||
+AS_IF([test "$TK" = "no"],
|
||||
+ [PY_STDLIB_MOD_SET_NA([_tkinter])])
|
||||
+
|
||||
# Check for enable-ipv6
|
||||
AH_TEMPLATE([ENABLE_IPV6], [Define if --enable-ipv6 is specified])
|
||||
|
Loading…
Reference in New Issue
Block a user