819cfcf7aa
Globally change Adam Duskett's email address to aduskett@gmail.com. Note that one or two of the patches may have been applied upstream with the old email address, but in that case those patches will anyway be removed when bumping. Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
48 lines
1.7 KiB
Diff
48 lines
1.7 KiB
Diff
From 2140db697c7f1da2a0a3f7bbcb14c1a0dade84e5 Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <aduskett@gmail.com>
|
|
Date: Mon, 9 Oct 2017 16:28:12 -0400
|
|
Subject: [PATCH] Add support for static-only build
|
|
|
|
Instead of unconditionally building shared libraries, this patch
|
|
improves the libsepol build system with a "STATIC" variable, which
|
|
when defined to some non-empty value, will disable the build of shared
|
|
libraries. It allows to support cases where the target architecture
|
|
does not have support for shared libraries.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Update for 2.8]
|
|
---
|
|
src/Makefile | 13 ++++++++++---
|
|
1 file changed, 10 insertions(+), 3 deletions(-)
|
|
|
|
diff -durNw libsepol-2.7.orig/src/Makefile libsepol-2.7/src/Makefile
|
|
--- libsepol-2.7.orig/src/Makefile 2018-01-15 21:07:51.285183415 +0100
|
|
+++ libsepol-2.7/src/Makefile 2018-01-15 21:08:56.515182717 +0100
|
|
@@ -39,7 +39,12 @@
|
|
LN=gln
|
|
endif
|
|
|
|
-all: $(LIBA) $(LIBSO) $(LIBPC)
|
|
+ALL_TARGETS = $(LIBA) $(LIBPC)
|
|
+ifeq ($(STATIC),)
|
|
+ALL_TARGETS += $(LIBSO)
|
|
+endif
|
|
+
|
|
+all: $(ALL_TARGETS)
|
|
|
|
|
|
$(LIBA): $(OBJS)
|
|
@@ -81,8 +86,10 @@
|
|
install: all
|
|
test -d $(DESTDIR)$(LIBDIR) || install -m 755 -d $(DESTDIR)$(LIBDIR)
|
|
install -m 644 $(LIBA) $(DESTDIR)$(LIBDIR)
|
|
+ifeq ($(STATIC),)
|
|
test -d $(DESTDIR)$(SHLIBDIR) || install -m 755 -d $(DESTDIR)$(SHLIBDIR)
|
|
install -m 755 $(LIBSO) $(DESTDIR)$(SHLIBDIR)
|
|
+endif
|
|
test -d $(DESTDIR)$(LIBDIR)/pkgconfig || install -m 755 -d $(DESTDIR)$(LIBDIR)/pkgconfig
|
|
install -m 644 $(LIBPC) $(DESTDIR)$(LIBDIR)/pkgconfig
|
|
$(LN) -sf --relative $(DESTDIR)$(SHLIBDIR)/$(LIBSO) $(DESTDIR)$(LIBDIR)/$(TARGET)
|