b7988b0fda
this patch bumps json-c to version 0.10 and adapts the no-reentrant patch to the new version. Signed-off-by: Andreas Wetzel <andreas.wetzel@nanotronic.ch> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
Do not pass -D_REENTRANT
|
|
|
|
This flag is not needed to build this library, and prevents to build
|
|
it with toolchains that don't have thread support.
|
|
|
|
Since the Makefile.in change is a one-liner, we also do it in the
|
|
patch to avoid having to autoreconfigure the package.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/Makefile.am.inc
|
|
===================================================================
|
|
--- a/Makefile.am.inc
|
|
+++ b/Makefile.am.inc
|
|
@@ -1,2 +1,2 @@
|
|
-AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
|
|
+AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
|
|
|
|
Index: b/Makefile.in
|
|
===================================================================
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -263,7 +263,7 @@
|
|
top_build_prefix = @top_build_prefix@
|
|
top_builddir = @top_builddir@
|
|
top_srcdir = @top_srcdir@
|
|
-AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
|
|
+AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
|
|
EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc json-c.vcproj
|
|
SUBDIRS = . tests
|
|
lib_LTLIBRARIES = libjson.la
|