8b500c1b63
Patch 0001-separate-lib-install.patch is no longer needed, original Makefile already contains separate install-lib target (but build always complete default target). Remove superfluous CFLAGS setting. Adjust 0002-extra-cflags.patch. Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
33 lines
931 B
Diff
33 lines
931 B
Diff
Makefile: append the CFLAGS to existing ones
|
|
|
|
Allow the user to pass custom CFLAGS (eg. optimisation flags).
|
|
|
|
Do not use EXTRA_CFLAGS, append to existing CFLAGS with += (Arnout)
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
Cc: Arnout Vandecappelle <arnout@mind.be>
|
|
|
|
---
|
|
Patch not sent upstream.
|
|
|
|
Although not specific to buildroot, I am not sure this is the best
|
|
way to handle user-supplied CFLAGS.
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 962f94eba661..bf6b317158cf 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -16,9 +16,10 @@ LOCAL_VERSION =
|
|
CONFIG_LOCALVERSION =
|
|
|
|
CPPFLAGS = -I libfdt -I .
|
|
-WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
|
+WARNINGS = -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
|
-Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls -Wshadow
|
|
-CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
|
|
+CFLAGS ?= -g -Os
|
|
+CFLAGS += -fPIC $(WARNINGS)
|
|
|
|
BISON = bison
|
|
LEX = flex
|