6520762932
Now that the cpython project has a nice Github repository, with tags, it's much nicer to handle the stack of Python patches with Git. The python3 package patches had already been converted, but not the python package patches. Therefore, this commit does the move. There is no functional change, only reformatting of the patches. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
43 lines
1.9 KiB
Diff
43 lines
1.9 KiB
Diff
From 3dc31a435b67de2ba3dd3457f0c939e20b58e8de Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Tue, 7 Mar 2017 22:17:06 +0100
|
|
Subject: [PATCH] setup.py: do not add invalid header locations
|
|
|
|
This piece of code incorrectly adds /usr/include to
|
|
self.compiler.include_dirs, and results in the following invalid
|
|
compilation line:
|
|
|
|
/home/thomas/projets/buildroot/output/host/usr/bin/arm-none-linux-gnueabi-gcc -fPIC \
|
|
-fno-strict-aliasing -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 \
|
|
-pipe -Os -DNDEBUG -g -O3 -Wall -Wstrict-prototypes \
|
|
-I/usr/include -I. -IInclude -I./Include \
|
|
-I/home/thomas/projets/buildroot/output/host/usr/arm-buildroot-linux-gnueabi/sysroot/usr/include \
|
|
-I/home/thomas/projets/buildroot/output/build/python-2.7.6/Include \
|
|
-I/home/thomas/projets/buildroot/output/build/python-2.7.6 \
|
|
-c /home/thomas/projets/buildroot/output/build/python-2.7.6/Modules/mathmodule.c \
|
|
-o build/temp.linux2-arm-2.7/home/thomas/projets/buildroot/output/build/python-2.7.6/Modules/mathmodule.o
|
|
cc1: warning: include location "/usr/include" is unsafe for cross-compilation [-Wpoison-system-directories]
|
|
[...]
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
setup.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 54054c2..64001e2 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -496,7 +496,7 @@ class PyBuildExt(build_ext):
|
|
for directory in reversed(options.dirs):
|
|
add_dir_to_list(dir_list, directory)
|
|
|
|
- if os.path.normpath(sys.prefix) != '/usr' \
|
|
+ if False and os.path.normpath(sys.prefix) != '/usr' \
|
|
and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
|
|
# OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
|
|
# (PYTHONFRAMEWORK is set) to avoid # linking problems when
|
|
--
|
|
2.7.4
|
|
|