f2ac23454f
This commit bumps the version of libtirpc to the latest upstream version 0.2.4, with the following changes on the patches: Updated to take into account minor upstream changes: - libtirpc-0001-Disable-parts-of-TIRPC-requiring-NIS-support.patch - libtirpc-0002-uClibc-without-RPC-support-does-not-install-rpcent.h.patch - libtirpc-0004-Make-IPv6-support-optional.patch - libtirpc-0008-Add-rpcgen-program-from-nfs-utils-sources.patch - libtirpc-0009-Automatically-generate-XDR-header-files-from-.x-sour.patch - libtirpc-0010-Add-more-XDR-files-needed-to-build-rpcbind-on-top-of.patch Removed since they were merged upstream: - libtirpc-0003-Add-missing-INET6-conditional.patch - libtirpc-0005-rpcent-mark-getrpcbyname-name-argument-as-const-char.patch - libtirpc-0006-rpcent-remove-prototypes-of-reentrant-variants.patch - libtirpc-0007-doc-Makefile.am-fix-out-of-tree-installation.patch Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
30 lines
918 B
Diff
30 lines
918 B
Diff
From a20f33ad121fb1e9d1fbc31a0044546450677e7a Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Sat, 23 Jun 2012 21:58:07 +0200
|
|
Subject: [PATCH] uClibc without RPC support does not install rpcent.h
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
tirpc/rpc/rpcent.h | 5 +++--
|
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/tirpc/rpc/rpcent.h b/tirpc/rpc/rpcent.h
|
|
index c865e51..45775ed 100644
|
|
--- a/tirpc/rpc/rpcent.h
|
|
+++ b/tirpc/rpc/rpcent.h
|
|
@@ -46,8 +46,9 @@
|
|
|
|
__BEGIN_DECLS
|
|
|
|
-/* These are defined in /usr/include/rpc/netdb.h */
|
|
-#if 0
|
|
+/* These are defined in /usr/include/rpc/netdb.h, unless we are using
|
|
+ the C library without RPC support. */
|
|
+#if defined(__UCLIBC__) && !defined(__UCLIBC_HAS_RPC__)
|
|
struct rpcent {
|
|
char *r_name; /* name of server for this rpc program */
|
|
char **r_aliases; /* alias list */
|
|
--
|
|
2.0.0
|
|
|