742f37de8d
Bump most QEMU defconfigs (every one that was previously on 5.4.y) to latest longterm kernel 5.10.7. Please note the following exceptions/modifications: - board/qemu/qemu_s390x_defconfig: ignored (already up to date) - board/qemu/sh4*-r2d: - Remove the remaining kernel patch [1] provided by Alan Modra fixing rodata alignment, carried here by Romain Naour [2] to fix an issue preventing kernel from booting with binutils 2.23. Patch is present in upstream Linux now. - Fix compile-time error regarding 64-bit time data structures from kernel headers when building with uclibc. Previous fix [3] existed upstream; but see details below. - board/qemu/ppc-mpc8544ds: Updated kernel patch - board/qemu/arm-versatile: Updated kernel patch - board/qemu/mips*r6*: Updated kernel patch Tested on all configs/qemu* configurations. [4] [1] https://www.sourceware.org/ml/binutils/2019-12/msg00112.html [2] https://git.busybox.net/buildroot/commit/?id=a2331c8a61bdd71c47492efc818fb0458a349219 [3] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=fc94cf2092c7c1267fa2deb8388d624f50eba808 [4] https://gitlab.com/clumsyape/buildroot/-/pipelines/244024195 Signed-off-by: Geoffrey Le Gourriérec <geoffrey.legourrierec@gmail.com> Reviewed-by: Joel Stanley <joel@jms.id.au> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
114 lines
3.8 KiB
Diff
114 lines
3.8 KiB
Diff
From 525dd2f3cf4a94837ce6b71d793acb90c25a5654 Mon Sep 17 00:00:00 2001
|
|
From: Waldemar Brodkorb <wbx@openadk.org>
|
|
Date: Fri, 1 Feb 2019 11:36:20 +0100
|
|
Subject: [PATCH] arm-versatile-nommu: Linux patch
|
|
|
|
Originally made by Waldemar Brodkorb <wbx@openadk.org> from LKML.
|
|
|
|
Signed-Off-by: Waldemar Brodkorb <wbx@openadk.org>
|
|
[Gerome: reformated as a Git patch]
|
|
Signed-off-by: Gerome Burlats <gerome.burlats@smile.fr>
|
|
[Romain: fix Waldemar's authorship in Git patch]
|
|
Signed-off-by: Romain Naour <romain.naour@smile.fr>
|
|
---
|
|
arch/arm/Kconfig | 11 +++++++++++
|
|
arch/arm/Kconfig.debug | 3 ++-
|
|
arch/arm/include/asm/mach/map.h | 1 +
|
|
arch/arm/mach-versatile/Kconfig | 5 +++--
|
|
arch/arm/mach-versatile/Makefile.boot | 3 +++
|
|
arch/arm/mach-versatile/versatile_dt.c | 4 ++++
|
|
6 files changed, 24 insertions(+), 3 deletions(-)
|
|
create mode 100644 arch/arm/mach-versatile/Makefile.boot
|
|
|
|
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
|
index 002e0cf025f5..c71299b6f91f 100644
|
|
--- a/arch/arm/Kconfig
|
|
+++ b/arch/arm/Kconfig
|
|
@@ -343,6 +343,17 @@ config ARM_SINGLE_ARMV7M
|
|
select SPARSE_IRQ
|
|
select USE_OF
|
|
|
|
+config ARM_SINGLE_ARCH_VERSATILE
|
|
+ bool "ARM Ltd. Versatile family"
|
|
+ depends on !MMU
|
|
+ select AUTO_ZRELADDR
|
|
+ select CLKSRC_OF
|
|
+ select COMMON_CLK
|
|
+ select GENERIC_CLOCKEVENTS
|
|
+ select GPIOLIB
|
|
+ select SPARSE_IRQ
|
|
+ select USE_OF
|
|
+
|
|
config ARCH_EBSA110
|
|
bool "EBSA-110"
|
|
select ARCH_USES_GETTIMEOFFSET
|
|
diff --git a/arch/arm/Kconfig.debug b/arch/arm/Kconfig.debug
|
|
index 8986a91a6f31..69cb6404e8ce 100644
|
|
--- a/arch/arm/Kconfig.debug
|
|
+++ b/arch/arm/Kconfig.debug
|
|
@@ -1943,7 +1943,8 @@ config DEBUG_UNCOMPRESS
|
|
config UNCOMPRESS_INCLUDE
|
|
string
|
|
default "debug/uncompress.h" if ARCH_MULTIPLATFORM || ARCH_MSM || \
|
|
- PLAT_SAMSUNG || ARM_SINGLE_ARMV7M
|
|
+ PLAT_SAMSUNG || ARM_SINGLE_ARMV7M || \
|
|
+ ARM_SINGLE_ARCH_VERSATILE
|
|
default "mach/uncompress.h"
|
|
|
|
config EARLY_PRINTK
|
|
diff --git a/arch/arm/include/asm/mach/map.h b/arch/arm/include/asm/mach/map.h
|
|
index 92282558caf7..90bd9c069ffc 100644
|
|
--- a/arch/arm/include/asm/mach/map.h
|
|
+++ b/arch/arm/include/asm/mach/map.h
|
|
@@ -59,6 +59,7 @@ extern int ioremap_page(unsigned long virt, unsigned long phys,
|
|
#else
|
|
#define iotable_init(map,num) do { } while (0)
|
|
#define vm_reserve_area_early(a,s,c) do { } while (0)
|
|
+#define debug_ll_io_init() do { } while (0)
|
|
#endif
|
|
|
|
#endif
|
|
diff --git a/arch/arm/mach-versatile/Kconfig b/arch/arm/mach-versatile/Kconfig
|
|
index d88e7725bf99..d38b90157f13 100644
|
|
--- a/arch/arm/mach-versatile/Kconfig
|
|
+++ b/arch/arm/mach-versatile/Kconfig
|
|
@@ -1,7 +1,8 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
config ARCH_VERSATILE
|
|
- bool "ARM Ltd. Versatile family"
|
|
- depends on ARCH_MULTI_V5
|
|
+ bool "ARM Ltd. Versatile family" if ARCH_MULTI_V5
|
|
+ depends on ARCH_MULTI_V5 || ARM_SINGLE_ARCH_VERSATILE
|
|
+ default y if ARM_SINGLE_ARCH_VERSATILE
|
|
select ARM_AMBA
|
|
select ARM_TIMER_SP804
|
|
select ARM_VIC
|
|
diff --git a/arch/arm/mach-versatile/Makefile.boot b/arch/arm/mach-versatile/Makefile.boot
|
|
new file mode 100644
|
|
index 000000000000..eacfc3f5c33e
|
|
--- /dev/null
|
|
+++ b/arch/arm/mach-versatile/Makefile.boot
|
|
@@ -0,0 +1,3 @@
|
|
+# Empty file waiting for deletion once Makefile.boot isn't needed any more.
|
|
+# Patch waits for application at
|
|
+# http://www.arm.linux.org.uk/developer/patches/viewpatch.php?id=7889/1 .
|
|
diff --git a/arch/arm/mach-versatile/versatile_dt.c b/arch/arm/mach-versatile/versatile_dt.c
|
|
index 02ba68abe533..835b51bc597b 100644
|
|
--- a/arch/arm/mach-versatile/versatile_dt.c
|
|
+++ b/arch/arm/mach-versatile/versatile_dt.c
|
|
@@ -22,7 +22,11 @@
|
|
#include <asm/mach/map.h>
|
|
|
|
/* macro to get at MMIO space when running virtually */
|
|
+#ifdef CONFIG_MMU
|
|
#define IO_ADDRESS(x) (((x) & 0x0fffffff) + (((x) >> 4) & 0x0f000000) + 0xf0000000)
|
|
+#else
|
|
+#define IO_ADDRESS(x) (x)
|
|
+#endif
|
|
#define __io_address(n) ((void __iomem __force *)IO_ADDRESS(n))
|
|
|
|
/*
|
|
--
|
|
2.17.1
|
|
|