738500c296
Add new host-pkgconf host python3 dependency.
Set new --with-build-python conf options for target python build.
Drop Fix cross compiling the uuid module patch which is no longer
required as pkgconfig is now used for include directory detection.
Refresh patches.
License hash changed due to year update:
ba00f0d93a
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
32 lines
1.3 KiB
Diff
32 lines
1.3 KiB
Diff
From 5d13e384b30a2c0b1c7b65718590b7fb0c3ba55e Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 11:36:00 +0100
|
|
Subject: [PATCH] Don't look in /usr/lib/termcap for libraries
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
setup.py | 5 +----
|
|
1 file changed, 1 insertion(+), 4 deletions(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index e496ee34c2..1904898165 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -1107,12 +1107,9 @@ def detect_readline_curses(self):
|
|
pass # Issue 7384: Already linked against curses or tinfo.
|
|
elif curses_library:
|
|
readline_libs.append(curses_library)
|
|
- elif self.compiler.find_library_file(self.lib_dirs +
|
|
- ['/usr/lib/termcap'],
|
|
- 'termcap'):
|
|
+ elif self.compiler.find_library_file(self.lib_dirs, 'termcap'):
|
|
readline_libs.append('termcap')
|
|
self.add(Extension('readline', ['readline.c'],
|
|
- library_dirs=['/usr/lib/termcap'],
|
|
libraries=readline_libs))
|
|
else:
|
|
self.missing.append('readline')
|
|
--
|
|
2.34.1
|
|
|