610d64b4b9
Update patch to also pass include directory for mysql headers, and get rid of host directories in -L / -I arguments. Finally look in staging rather than target for libmysqlclient. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
24 lines
989 B
Diff
24 lines
989 B
Diff
From: Baruch Siach <baruch@tkos.co.il>
|
|
Subject: [PATCH] poco: add the staging path to search path
|
|
|
|
Add the mysql headers and client libraries to the search path of the
|
|
preprocessor and the linker. The $MYSQL_LIBDIR / $MYSQL_INCIDR variables
|
|
must be set from the make command line.
|
|
|
|
[Peter: Remove host dirs, add MYSQL_INCDIR]
|
|
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
|
---
|
|
--- poco-1.4.1p1-all-dist/Data/MySQL/Makefile 2011-02-09 11:13:00.000000000 +0200
|
|
+++ poco-1.4.1p1-all/Data/MySQL/Makefile 2011-08-07 09:03:37.106161274 +0300
|
|
@@ -8,8 +8,8 @@
|
|
|
|
include $(POCO_BASE)/build/rules/global
|
|
|
|
-SYSLIBS += -L/usr/local/lib/mysql -L/usr/lib/mysql -L/usr/mysql/lib/mysql -L/usr/local/mysql/lib -lmysqlclient
|
|
-INCLUDE += -I/usr/local/include/mysql/ -I/usr/include/mysql -I/usr/mysql/include/mysql -I/usr/local/mysql/include
|
|
+SYSLIBS += -L$(MYSQL_LIBDIR) -lmysqlclient
|
|
+INCLUDE += -I$(MYSQL_INCDIR)
|
|
SYSFLAGS += -DTHREADSAFE -DNO_TCL
|
|
|
|
objects = Binder Extractor SessionImpl Connector \
|