kumquat-buildroot/package/gstreamer/gst-plugins-base/gst-plugins-base.mk
Ricardo Martincoski c07a46b0ce gst-plugins-base: fix handling of freetype
In 2010 commit 32d319e6f "gst-plugins-base: ensure <stdint.h> is used"
introduced a typo (missing backslash) that made the code ineffective.

It can be confirmed by looking at the output of:
$ make printvars | grep '^GST_PLUGINS_BASE_CONF_ENV\|^FT2_CONFIG'
FT2_CONFIG=/bin/false ac_cv_header_stdint_t="stdint.h"
GST_PLUGINS_BASE_CONF_ENV=

Add the missing backslash to fix the code.
While at it, fix the indentation to use one tab instead of two.

The (end of the) diff of config.log confirms the code is still needed
when the host has freetype-config installed:
@@ -1674,10 +1674,8 @@
 configure:21882: checking for emmintrin.h
 configure:21882: result: no
 configure:21894: checking for stdint types
-configure:21917: /tmp/gst/output/host/usr/bin/i686-pc-linux-gnu-gcc -std=gnu99 -c   conftest.c >&5
-configure:21917: $? = 0
 configure:21961: result: stdint.h (shortcircuit)
-configure:22348: result: make use of stdint.h in _stdint.h (assuming C99 compatible system)
+configure:22348: result: make use of stdint.h in _stdint.h
 configure:22359: checking for localtime_r
 configure:22359: /tmp/gst/output/host/usr/bin/i686-pc-linux-gnu-gcc -std=gnu99 -o conftest -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Os  -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  conftest.c  >&5
 configure:22359: $? = 0
@@ -2468,8 +2466,7 @@
 Package 'freetype2', required by 'world', not found
 configure:31257: result: no
 configure:31298: checking for freetype-config
-configure:31316: found /usr/bin/freetype-config
-configure:31329: result: /usr/bin/freetype-config
+configure:31329: result: /bin/false
 configure:31339: checking for FreeType - version >= 2.0.9
 configure:31427: result: yes
 configure:32250: creating ./config.status
@@ -2789,7 +2786,7 @@
 ac_cv_objext='o'
 ac_cv_path_EGREP='/bin/grep -E'
 ac_cv_path_FGREP='/bin/grep -F'
-ac_cv_path_FT2_CONFIG='/usr/bin/freetype-config'
+ac_cv_path_FT2_CONFIG='/bin/false'
 ac_cv_path_GMSGFMT='/tmp/gst/output/host/usr/bin/msgfmt'
 ac_cv_path_GREP='/bin/grep'
 ac_cv_path_MSGFMT='/tmp/gst/output/host/usr/bin/msgfmt'
@@ -2818,7 +2815,6 @@
 ac_cv_prog_cxx_g='yes'
 ac_cv_prog_make_make_set='yes'
 ac_cv_stdint_message='using gnu compiler i686-pc-linux-gnu-gcc (Sourcery CodeBench Lite 2012.09-62) 4.7.2'
-ac_cv_stdint_result='(assuming C99 compatible system)'
 ac_cv_sys_file_offset_bits='no'
 ac_cv_sys_largefile_CC='no'
 ac_cv_sys_largefile_source='no'
@@ -2965,9 +2961,9 @@
 EXEEXT=''
 FFLAGS=' -Os '
 FGREP='/bin/grep -F'
-FT2_CFLAGS='-I/usr/include/freetype2'
-FT2_CONFIG='/usr/bin/freetype-config'
-FT2_LIBS='-lfreetype'
+FT2_CFLAGS=''
+FT2_CONFIG='/bin/false'
+FT2_LIBS=''
 GCOV=''
 GCOV_CFLAGS=''
 GCOV_LIBS=''

Detected by check-package.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2017-04-12 21:05:34 +02:00

197 lines
5.4 KiB
Makefile

################################################################################
#
# gst-plugins-base
#
################################################################################
GST_PLUGINS_BASE_VERSION = 0.10.36
GST_PLUGINS_BASE_SOURCE = gst-plugins-base-$(GST_PLUGINS_BASE_VERSION).tar.xz
GST_PLUGINS_BASE_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-base
GST_PLUGINS_BASE_INSTALL_STAGING = YES
GST_PLUGINS_BASE_LICENSE = GPL-2.0+, LGPL-2.0+
GST_PLUGINS_BASE_LICENSE_FILES = COPYING COPYING.LIB
# freetype is only used by examples, but if it is not found
# and the host has a freetype-config script, then the host
# include dirs are added to the search path causing trouble
GST_PLUGINS_BASE_CONF_ENV = \
FT2_CONFIG=/bin/false \
ac_cv_header_stdint_t="stdint.h"
GST_PLUGINS_BASE_CONF_OPTS = \
--disable-examples \
--disable-oggtest \
--disable-vorbistest \
--disable-freetypetest
GST_PLUGINS_BASE_DEPENDENCIES = gstreamer
ifeq ($(BR2_PACKAGE_XORG7),y)
GST_PLUGINS_BASE_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXv
GST_PLUGINS_BASE_CONF_OPTS += \
--enable-x \
--enable-xshm \
--enable-xvideo
else
GST_PLUGINS_BASE_CONF_OPTS += \
--disable-x \
--disable-xshm \
--disable-xvideo
endif
ifeq ($(BR2_PACKAGE_ORC),y)
GST_PLUGINS_BASE_DEPENDENCIES += orc
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ALSA),y)
GST_PLUGINS_BASE_DEPENDENCIES += alsa-lib
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-alsa
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ADDER),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-adder
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-adder
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_APP),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-app
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-app
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_AUDIOCONVERT),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-audioconvert
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-audioconvert
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_AUDIORATE),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-audiorate
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-audiorate
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_AUDIORESAMPLE),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-audioresample
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-audioresample
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_AUDIOTESTSRC),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-audiotestsrc
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-audiotestsrc
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ENCODING),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-encoding
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-encoding
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_FFMPEGCOLORSPACE),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-ffmpegcolorspace
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-ffmpegcolorspace
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_GDP),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-gdp
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-gdp
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_PLAYBACK),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-playback
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-playback
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_SUBPARSE),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-subparse
GST_PLUGINS_BASE_DEPENDENCIES += libxml2
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-subparse
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_TCP),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-tcp
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-tcp
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_TYPEFIND),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-typefind
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-typefind
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VIDEOTESTSRC),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-videotestsrc
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-videotestsrc
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VIDEORATE),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-videorate
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-videorate
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VIDEOSCALE),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-videoscale
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-videoscale
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VOLUME),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-volume
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-volume
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_OGG),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-ogg
GST_PLUGINS_BASE_DEPENDENCIES += libogg
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-ogg
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_PANGO),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-pango
GST_PLUGINS_BASE_DEPENDENCIES += pango
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-pango
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_THEORA),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-theora
GST_PLUGINS_BASE_DEPENDENCIES += libtheora
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-theora
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_TREMOR),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-ivorbis
GST_PLUGINS_BASE_DEPENDENCIES += tremor
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-ivorbis
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VORBIS),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-vorbis
GST_PLUGINS_BASE_DEPENDENCIES += libvorbis
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-vorbis
endif
ifeq ($(BR2_PACKAGE_ZLIB),y)
GST_PLUGINS_BASE_DEPENDENCIES += zlib
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-zlib
endif
$(eval $(autotools-package))