3d6aec1fa6
Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
29 lines
953 B
Diff
29 lines
953 B
Diff
From cb6c4ff053e72f7fe5954894aebe2c0d94120b2d Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@openwide.fr>
|
|
Date: Thu, 3 Oct 2013 23:22:17 +0200
|
|
Subject: [PATCH 5/5] [FIX] Linux Powerlink user lib: add INSTALL
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
|
|
---
|
|
Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt b/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt
|
|
index e67d573..40b7756 100644
|
|
--- a/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt
|
|
+++ b/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt
|
|
@@ -329,7 +329,9 @@ ENDIF ()
|
|
#
|
|
# Installation
|
|
#
|
|
-IF (WIN32)
|
|
+IF (UNIX)
|
|
+ INSTALL(TARGETS powerlink ARCHIVE DESTINATION lib)
|
|
+ELSEIF (WIN32)
|
|
IF (CFG_X86_WINDOWS_DLL)
|
|
INSTALL(TARGETS openPOWERLINK RUNTIME DESTINATION bin)
|
|
ENDIF (CFG_X86_WINDOWS_DLL)
|
|
--
|
|
1.8.4
|
|
|