2cfa86a548
Needed for compatibility with OpenSSL 3.x which was added in version 25:f11a9f2d3a
Added dependency to wchar due to upstream commitbd0865ff86
Removed all patches. Added new patch to fix build with defconfig bootlin-x86-64-uclibc. CVE-2021-29221 does not need to be ignored anymore, the latest broken version was 23.2.3. Removed ERLANG_REMOVE_SSL_DEPS hook, bug was fixed upstream:f03feee7e3
Updated ERLANG_RUN_AUTOCONF due to upstream commitd277599a42 (diff-9d7b6b593fbd689e1f48ba5964dc3bcc87c51e8e1aab5ff496a4e5ba3a248775R1233)
Signed-off-by: Bernd Kuhls <bernd@kuhls.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
45 lines
1.4 KiB
Diff
45 lines
1.4 KiB
Diff
From ede1e17794c2caf091e810bdfa49040c75f513eb Mon Sep 17 00:00:00 2001
|
|
From: Bernd Kuhls <bernd@kuhls.net>
|
|
Date: Sat, 15 Jul 2023 18:36:48 +0200
|
|
Subject: [PATCH] erts: check for sys/auxv.h
|
|
|
|
Upstream: https://github.com/erlang/otp/pull/7500
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
|
|
---
|
|
erts/configure.ac | 2 +-
|
|
erts/emulator/asmjit/core/cpuinfo.cpp | 2 ++
|
|
2 files changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/erts/configure.ac b/erts/configure.ac
|
|
index a63d391fb3..9d3e338633 100644
|
|
--- a/erts/configure.ac
|
|
+++ b/erts/configure.ac
|
|
@@ -1655,7 +1655,7 @@ AC_CHECK_HEADERS(fcntl.h limits.h unistd.h syslog.h dlfcn.h ieeefp.h \
|
|
sys/socket.h sys/sockio.h sys/socketio.h \
|
|
net/errno.h malloc.h arpa/nameser.h libdlpi.h \
|
|
pty.h util.h libutil.h utmp.h langinfo.h poll.h sdkddkver.h \
|
|
- elf.h)
|
|
+ elf.h sys/auxv.h)
|
|
|
|
AC_CHECK_MEMBERS([struct ifreq.ifr_hwaddr], [], [],
|
|
[#ifdef __WIN32__
|
|
diff --git a/erts/emulator/asmjit/core/cpuinfo.cpp b/erts/emulator/asmjit/core/cpuinfo.cpp
|
|
index fb2acfc09b..d8b72697ab 100644
|
|
--- a/erts/emulator/asmjit/core/cpuinfo.cpp
|
|
+++ b/erts/emulator/asmjit/core/cpuinfo.cpp
|
|
@@ -15,8 +15,10 @@
|
|
|
|
// Required by `getauxval()` on Linux.
|
|
#if defined(__linux__)
|
|
+#if defined(HAVE_SYS_AUXV_H)
|
|
#include <sys/auxv.h>
|
|
#endif
|
|
+#endif
|
|
|
|
//! Required to detect CPU and features on Apple platforms.
|
|
#if defined(__APPLE__)
|
|
--
|
|
2.39.2
|
|
|