kumquat-buildroot/package/x11r7/xserver_xorg-server/0004-hw-xwayland-Makefile.am-fix-build-without-glx.patch
Peter Korsgaard c287d789b7 Merge branch 'next'
A number of merge conflicts, but hopefully they are all sorted out now.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2020-09-02 18:14:46 +02:00

46 lines
1.4 KiB
Diff

From b1d2a82d644518c1a75775244ac63be738aaf062 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Fri, 19 Apr 2019 10:19:50 +0200
Subject: [PATCH] hw/xwayland/Makefile.am: fix build without glx
Commit d8ec33fe0542141aed1d9016d2ecaf52da944b4b added libglxvnd.la to
Xwayland_LDFLAGS but GLX can be disabled through --disable-glx.
In this case, build fails on:
make[3]: *** No rule to make target '../../glx/libglxvnd.la', needed by 'Xwayland'. Stop.
make[3]: *** Waiting for unfinished jobs....
Fixes:
- http://autobuild.buildroot.org/results/397f8098c57fc6c88aa12dc8d35ebb1b933d52ef
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status:
https://gitlab.freedesktop.org/xorg/xserver/merge_requests/173]
---
hw/xwayland/Makefile.am | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/hw/xwayland/Makefile.am b/hw/xwayland/Makefile.am
index bc1cb8506..502879e2a 100644
--- a/hw/xwayland/Makefile.am
+++ b/hw/xwayland/Makefile.am
@@ -21,10 +21,14 @@ Xwayland_SOURCES = \
$(top_srcdir)/Xi/stubs.c \
$(top_srcdir)/mi/miinitext.c
+if GLX
+GLXVND_LIB = $(top_builddir)/glx/libglxvnd.la
+endif
+
Xwayland_LDADD = \
$(glamor_lib) \
$(XWAYLAND_LIBS) \
- $(top_builddir)/glx/libglxvnd.la \
+ $(GLXVND_LIB) \
$(XWAYLAND_SYS_LIBS) \
$(top_builddir)/Xext/libXvidmode.la \
$(XSERVER_SYS_LIBS)
--
2.20.1