187c6ef3c6
- Remove first patch and pass CC_FOR_BUILD and other variables in LIBXMLRPC_CONF_OPTS instead of LIBXMLRPC_CONF_ENV because a similar solution is already in version thanks to https://sourceforge.net/p/xmlrpc-c/code/2905 - Remove second patch (already in version thanks to https://sourceforge.net/p/xmlrpc-c/code/2908) - Remove third path (already in version thanks to https://sourceforge.net/p/xmlrpc-c/code/2909) - Add hash for license file Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
71 lines
2.5 KiB
Diff
71 lines
2.5 KiB
Diff
Use correct curl-config program
|
|
|
|
Instead of calling directly curl-config in src/Makefile (which ends up
|
|
calling the wrong curl-config: the one in the PATH instead of the one
|
|
pointed at by the environment variables at configure time), let's
|
|
define a CURL_CONFIG variable that contains the path to the proper
|
|
curl-config program, and use it where appropriate.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/src/Makefile
|
|
===================================================================
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -57,7 +57,7 @@
|
|
TRANSPORT_MODS += $(BLDDIR)/lib/curl_transport/xmlrpc_curl_transport
|
|
TRANSPORT_MODS += $(BLDDIR)/lib/curl_transport/curltransaction
|
|
TRANSPORT_MODS += $(BLDDIR)/lib/curl_transport/curlmulti
|
|
- TRANSPORT_LIBDEP += $(shell curl-config --libs)
|
|
+ TRANSPORT_LIBDEP += $(shell $CURL_CONFIG --libs)
|
|
TRANSPORT_INCLUDES += -Isrcdir/lib/curl_transport
|
|
endif
|
|
ifeq ($(MUST_BUILD_LIBWWW_CLIENT),yes)
|
|
Index: b/config.mk.in
|
|
===================================================================
|
|
--- a/config.mk.in
|
|
+++ b/config.mk.in
|
|
@@ -32,6 +32,7 @@
|
|
LSOCKET = @LSOCKET@
|
|
WININET_LDADD = @WININET_LDADD@
|
|
WININET_LIBDIR = @WININET_LIBDIR@
|
|
+CURL_CONFIG = @CURL_CONFIG@
|
|
CURL_LDADD = @CURL_LDADD@
|
|
CURL_LIBDIR = @CURL_LIBDIR@
|
|
LIBWWW_LDADD = @LIBWWW_LDADD@
|
|
Index: b/configure.in
|
|
===================================================================
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -550,6 +550,8 @@
|
|
dnl So we don't do any check now. If we find out there's a problem with
|
|
dnl older Curls, we will revisit that.
|
|
|
|
+ AC_SUBST(CURL_CONFIG)
|
|
+
|
|
CURL_LDADD=$($CURL_CONFIG --libs)
|
|
AC_SUBST(CURL_LDADD)
|
|
|
|
Index: b/lib/curl_transport/Makefile
|
|
===================================================================
|
|
--- a/lib/curl_transport/Makefile
|
|
+++ b/lib/curl_transport/Makefile
|
|
@@ -29,7 +29,7 @@
|
|
|
|
$(SRCDIR)/common.mk: srcdir blddir
|
|
|
|
-CURL_VERSION := $(shell curl-config --vernum)
|
|
+CURL_VERSION := $(shell $(CURL_CONFIG) --vernum)
|
|
|
|
# Some time at or before Curl 7.12, <curl/types.h> became an empty file
|
|
# (no-op). Some time after Curl 7.18, <curl/types.h> ceased to exist.
|
|
@@ -43,7 +43,7 @@
|
|
CFLAGS_LOCAL += -DNEED_CURL_TYPES_H
|
|
endif
|
|
|
|
-CURL_INCLUDES := $(shell curl-config --cflags)
|
|
+CURL_INCLUDES := $(shell $(CURL_CONFIG) --cflags)
|
|
# We expect that curl-config --cflags just gives us -I options, because
|
|
# we need just the -I options for 'make dep'. Plus, it's scary to think
|
|
# of what any other compiler flag would do to our compile.
|